httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gaurav Pruthi" <gkpru...@gmail.com>
Subject [users@httpd] Problem while compiling Apache 2.26 Modules
Date Fri, 01 Feb 2008 03:58:49 GMT
Hi,

I am using apache 2.26. I configured apache using the following configure
command

./configure --prefix=/usr/local/apache --enable-module=so
--enable-shared=rewrite --enable-module=rewrite --enable-module=cgi
--enable-module=unique_id --enable-shared=unique_id --with-expat=builtin

Apache installed successfully but when i checked for modules, mod_unique_id
& mod_rewrite in /usr/local/apache/modules directory, i found them missing.
Then i tried installing mod_unique_id using as dso module. But i got error

*Warning!  dlname not found in /usr/local/apache/modules/mod_unique_id.la.*

See the detailed error below

/usr/local/apache/bin/apxs -cia mod_unique_id.c
/usr/local/apache/build/libtool --silent --mode=compile gcc -prefer-pic
-DLINUX=2 -D_REENTRANT -D_GNU_SOURCE -g -O2 -pthread
-I/usr/local/apache/include  -I/usr/local/apache/include
-I/usr/local/apache/include   -c -o mod_unique_id.lo mod_unique_id.c &&
touch mod_unique_id.slo
/usr/local/apache/build/libtool --silent --mode=link gcc -o
mod_unique_id.la  -rpath /usr/local/apache/modules -module -avoid-version
mod_unique_id.lo
/usr/local/apache/build/instdso.sh
SH_LIBTOOL='/usr/local/apache/build/libtool' mod_unique_id.la
/usr/local/apache/modules
/usr/local/apache/build/libtool --mode=install cp mod_unique_id.la
/usr/local/apache/modules/
cp .libs/mod_unique_id.lai /usr/local/apache/modules/mod_unique_id.la
cp .libs/mod_unique_id.a /usr/local/apache/modules/mod_unique_id.a
chmod 644 /usr/local/apache/modules/mod_unique_id.a
ranlib /usr/local/apache/modules/mod_unique_id.a
PATH="$PATH:/sbin" ldconfig -n /usr/local/apache/modules
----------------------------------------------------------------------
Libraries have been installed in:
   /usr/local/apache/modules

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
   - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
     during execution
   - add LIBDIR to the `LD_RUN_PATH' environment variable
     during linking
   - use the `-Wl,--rpath -Wl,LIBDIR' linker flag
   - have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------
Warning!  dlname not found in /usr/local/apache/modules/mod_unique_id.la.
Assuming installing a .so rather than a libtool archive.
chmod 755 /usr/local/apache/modules/mod_unique_id.so
chmod: cannot access `/usr/local/apache/modules/mod_unique_id.so': No such
file or directory
apxs:Error: Command failed with rc=65536

Here are inbuilt apache modules

/usr/local/apache/bin/httpd -l Compiled in modules:
  core.c
  mod_authn_file.c
  mod_authn_default.c
  mod_authz_host.c
  mod_authz_groupfile.c
  mod_authz_user.c
  mod_authz_default.c
  mod_auth_basic.c
  mod_include.c
  mod_filter.c
  mod_log_config.c
  mod_env.c
  mod_setenvif.c
  prefork.c
  http_core.c
  mod_mime.c
  mod_status.c
  mod_autoindex.c
  mod_asis.c
  mod_cgi.c
  mod_negotiation.c
  mod_dir.c
  mod_actions.c
  mod_userdir.c
  mod_alias.c
  mod_so.c



Please suggest me if i am missing anything.

-- 
Gaurav Pruthi

Mime
View raw message