httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kai Schaetzl <mailli...@conactive.com>
Subject [users@httpd] name-based virtual hosts not working on 2.2?
Date Sun, 10 Feb 2008 16:06:15 GMT
NO, this is not an FAQ!

The apache 2.2.3 coming with CentOS 5 cannot identify name-based virtual 
hosts for SSL anymore. It goes straight to the first virtual host. This 
worked with Apache 1.3 and still works with Apache 2.0. I just started 
investigating what I need to change moving from 2.0 to 2.2 and find that 
this functionality suddenly stopped working with 2.2.
I cannot see any change concerning this in the upgrade guide for 2.2 and 
the changelog for 2.2 also lists only one change in this area for 2.1.9 
which implies it should work.
The few related bug reports I can find all suggest that it *should* work:
http://issues.apache.org/bugzilla/show_bug.cgi?id=43997
http://issues.apache.org/bugzilla/show_bug.cgi?id=41537
The wiki also implies it should work:
http://wiki.apache.org/httpd/CommonMisconfigurations#head-
f1f4514b7f635005fe921a19afa007f3b6526a0e

I'm wondering if the Apache 2.2.3 in CentOS is broken, if it is a general 
bug in Apache 2.2 or if it is a "silent" design change in Apache 2.2.
Can anyone make name-based virtual hosts with SSL work on 2.2?

(Just to avoid getting some standard answers: using name-based virtual 
hosts with SSL *is* useful if you use the same wildcard certificate for 
the virtual hosts and hostnames like webmail1.example.org, 
webmail2.example.org etc. It has worked fine for years with the major 
browsers and before Apache 2.2.)


Kai



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message