httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ruslan Sivak <rsi...@istandfor.com>
Subject Re: [users@httpd] Multiple VirtualHosts with the same name
Date Sun, 24 Feb 2008 00:31:21 GMT
Joshua Slive wrote:
> On Sat, Feb 23, 2008 at 2:54 PM, Ruslan Sivak <rsivak@istandfor.com> wrote:
>   
>> I'm having a bit of a problem.  I  have a loadbalancer go to two virtual
>>  servers on one real server.  Something like
>>
>>  Listen 80
>>  NameVirtualHost *:80
>>
>>  <VirtualHost 192.168.0.2:80>
>>  HostName www.myhostname.com
>>  ...
>>  </VirtualHost>
>>
>>
>>  <VirtualHost 192.168.0.3:80>
>>  HostName www.myhostname.com
>>  ...
>>  </VirtualHost>
>>
>>
>>  <VirtualHost 192.168.0.2:80>
>>  HostName www.someotherhostname.com
>>  ....
>>  </VirtualHost>
>>
>>
>>
>>  Hosts one and two work fine, but the third host gets matched by the
>>  first one.  How can I make it match properly?
>>     
>
> What does the Host header look like when it gets to apache? I suspect
> your load balancer is sending a Host header that doesn't match
> www.someotherhostname.com, meaning there is no way for apache to route
> it correctly.
>
> Joshua.
>   

The host header is fine.  The third host is not going through the lb, 
but is pointed directly at this server, so that wouldn't be the issue.  
Hosts 1 and 2 work fine, so the host header is fine there too.

Russ



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message