httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Chase <ja...@chasecomputers.net>
Subject [users@httpd] webdav not authenticating on apache 2.2.3 - centos 5
Date Wed, 20 Feb 2008 20:47:55 GMT
I've been trying to get webdav to work with apache for a little while 
now and I must be missing something. Currently I just have the 
directives like this

<Location /var/www/html/dav/>
        DAV on
</Location>

I just want to verify that webdav actually works. When trying to map the 
location with Windows XP it asks for a username/password which I don't 
understand why it should? I also tried a program called "Webdrive" and 
it was unable to connect and gave this error when authenticating as an 
anonymous user:

"Unable to connect to server, error information below
 
Error: HTTP Error response received from server, erorr=405 (4516)
Operation: Connecting to server
Server Response: 405 Method Not Allowed"

I tried the litmus test on the centos machine and got this:

"[root@linux james]# /usr/local/bin/litmus http://192.168.1.8/dav/
-> running `basic':
 0. init.................. pass
 1. begin................. FAIL (Could not create new collection 
`/dav/litmus/' for tests: 405 Method Not Allowed
Server must allow `MKCOL /dav/litmus/' for tests to proceed)
<- summary for `basic': of 2 tests run: 1 passed, 1 failed. 50.0%
See debug.log for network/debug traces."

The directory permissions look fine...owned by apache:apache and 775

Before this I was using a .htpasswd file and had authentication on in 
the apache directives but the usernames and passwords I added to the 
file would not work. It had the exact same problem I have now. I'm sure 
it's something simple and I'm an idiot -- I just can't figure it out   =o(



---
[This E-mail scanned for viruses by Declude EVA]



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message