httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Covener" <cove...@gmail.com>
Subject Re: [users@httpd] Runtime definitions missing for 2.2.8 on AIX 5.3
Date Thu, 14 Feb 2008 17:36:35 GMT
On Thu, Feb 14, 2008 at 10:30 AM, O'DELL, TODD E (ATTOPS)
<to2958@att.com> wrote:
> I'm able to build the 2.2.8 Apache on a AIX 5.3 server. It will compile
>  and install but when I go to start it I get this:
>
>  exec(): 0509-036 Cannot load program httpd because of the following
>  errors:
>  rtld: 0712-001 Symbol XML_ParserFree was referenced
>       from module /web/apache/production/lib/libaprutil-1.so(), but a
>  runtime definition
>       of the symbol was not found.

ISTR a problem with libtool on AIX where the relinkde/installed
version of apr-util has a hard-coded reference to expat that cannot be
overridden by LIBPATH. This should only affect running the Apache code
on a different system, as the hard-coded path ought to at least be
correct.

You might want to try temporarily using the apr-util libs from
srclib/apr-util/.libs/ instead of the ones re-linked by libtool, and
see if it helps at all.

You might also want to try picking up a newer libtool and re-building.

-- 
Eric Covener
covener@gmail.com

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message