httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Udo Rader <udo.ra...@bestsolution.at>
Subject Re: [users@httpd] reverse https to http proxy not fully working
Date Thu, 21 Feb 2008 21:28:10 GMT

Am Donnerstag, den 21.02.2008, 21:10 +0000 schrieb Nick Kew:
> On Thu, 21 Feb 2008 21:30:14 +0100
> Udo Rader <udo.rader@bestsolution.at> wrote:
> 
> 
> > My reverse proxying configuration looks like this:
> 
> Heh.  Missed this in my previous reply.
> 
> > --------CUT-------
> > ProxyPass /someApp/ http://internal.example.com/someApp/
> 
> With that /someApp/ in the target, you need to *preserve*
> that part of the URL.  Your current rules will erase it, to
> work with the more usual case of
> ProxyPass /someApp/ http://internal.example.com/

Hmm, ok, I've first added the trailing slash to be like this:

ProxyHTMLURLMap http://internal.example.com/someApp/ /someApp/

but that did not change anything, and the logs don't show anything, with
logging active like this:

ProxyHTMLLogVerbose On
LogLevel Info

Now you say that I should change my ProxyPass directive, but how would
that work? Internally the application I am trying to proxy is reachable
via /someApp ...

But in order to give it a try, I changed my configuration like this:

ProxyPass /internal/ http://internal.example.com/

<Location /internal/>
        ProxyPassReverse /
</Location>

Now still, if I access my https proxy with

https://reverseproxy.example.com/internal/someApp/

I still see this 

<link rel="stylesheet" type="text/css"
href="http://reverseproxy.example.com/someApp/css/default.css" />

... thanks :-)

-- 
B e s t S o l u t i o n . a t                        EDV Systemhaus GmbH
------------------------------------------------------------------------
udo rader              technischer leiter/CTO
------------------------------------------------------------------------
eduard-bodem-gasse 8/3    A-6020 innsbruck      phone    ++43 512 935834

Mime
View raw message