httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rafal Markut" <rafal.mar...@mediawave.de>
Subject [users@httpd] Very strange problem with forms ...
Date Mon, 11 Feb 2008 13:58:14 GMT
Hello,

I know that this list isn't for web developping but I have impression that 
maybe apache makes problems so I'm writting here ...

I made very simple web application. Namely on the main page there is list of 
records (list.jsp). I can create new record, edit and delete.

So when user clicks ADD or EDIT then new page appears (article.jsp) with 2 
form fields, and ...
when user press SAVE then:
1. it goes to article.jsp
2. check if information from these 2 fields are valid
3. makes INSERT or UPDATE in the database
4. performs redirection to the list.jsp.

Normally it works perfectly ... but sometimes when the user press SAVE then 
it lands again in article.jsp and it doesn't save the data. Here are two 
cases:

1. Sometimes when the user press SAVE then he sees form with data (which he 
typed in) but he can press SAVE 100 times but stil he sees this same filled 
form (he doesn't save in the database and doesn't jump to the list.jsp).

2. OR ... sometimes when the user press SAVE then he sees empty form but 
user can fill form again and press SAVE  but stil he sees this same empty 
form (he doesn't save in the database and doesn't jump to list.jsp).

Of course the form-data are in both cases valid.

It helps only when user closes browser and opens it again. About 60-70 users 
works with that application. Most of them works with Internet Explorer 6. It 
happens only sometimes.
I wasn't able to reproduce this error, it didn't happen to me.

I made this application in JSF+Spring+Hibernate. I wasn't able to find the 
solution, I coundn't reproduce error and find the reason.

So I made this application so simple as it's possible, namely in pure JSP, 
connection with database via JDBC.

I made thousands such applications and i didn't have such strange problems.
This forms behaves like POST data would be removed (all or partly).

There are no any exceptions or errors in logs.

Do you have any idea what could it be ? Did anyone have such problems ?

Tomcat 5.5
Apache 2.0.59, Apache 2.0 Filter
MySql 5.0.18

with best regards,
Rafal 


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message