httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brendan.McKe...@mdsuk.com
Subject [users@httpd] Load balancing problem
Date Tue, 08 Jan 2008 12:05:40 GMT
Hi,

        I am running httpd version 2.2.6 on Windows XP SP2.  I am trying 
to use sticky sessions to route users to a server, based on the value of 
the JSESSIONID cookie in their request.  While the load balancing does 
appear to work, the sticky sessions don't appear to be working.  My 
configuration looks like this:

ProxyRequests   Off
<Location /selfcare> 
    ProxyPass balancer://selfcare stickysession=JSESSIONID 
</Location>
<Proxy balancer://selfcare>
    BalancerMember http://host1:1109/selfcare loadfactor=1 route=1
    BalancerMember http://host2:1109/selfcare loadfactor=1 route=2
    ProxySet lbmethod=byrequests
    #ProxySet lbmethod=bytraffic
</Proxy>

        The error.log file, however contains the following, which appears 
to me to mean that even though it's finding the JSESSIONID cookie, it's 
not routing the requests to the same host:

[Tue Jan 08 12:01:14 2008] [debug] mod_proxy_balancer.c(41): proxy: 
BALANCER: canonicalising URL //selfcare/app/index.jsp
[Tue Jan 08 12:01:14 2008] [debug] mod_proxy_balancer.c(258): proxy: 
BALANCER: Found value (null) for stickysession JSESSIONID
[Tue Jan 08 12:01:14 2008] [debug] mod_proxy_balancer.c(950): proxy: 
Entering byrequests for BALANCER (balancer://selfcare)
[Tue Jan 08 12:01:14 2008] [debug] mod_proxy_balancer.c(517): proxy: 
BALANCER (balancer://selfcare) worker (http://host1:1109/selfcare) 
rewritten to http://host1:1109/selfcare/app/index.jsp
[Tue Jan 08 12:01:14 2008] [debug] mod_proxy.c(819): Running scheme 
balancer handler (attempt 0)
[Tue Jan 08 12:01:14 2008] [debug] mod_proxy_http.c(1693): proxy: HTTP: 
serving URL http://host1:1109/selfcare/app/index.jsp
[Tue Jan 08 12:01:14 2008] [debug] proxy_util.c(1852): proxy: HTTP: has 
acquired connection for (host1)
[Tue Jan 08 12:01:14 2008] [debug] proxy_util.c(1913): proxy: connecting 
http://host1:1109/selfcare/app/index.jsp to host1:1109
[Tue Jan 08 12:01:14 2008] [debug] proxy_util.c(2012): proxy: connected 
/selfcare/app/index.jsp to host1:1109
[Tue Jan 08 12:01:14 2008] [debug] proxy_util.c(2169): proxy: HTTP: fam 2 
socket created to connect to host1
[Tue Jan 08 12:01:15 2008] [debug] proxy_util.c(2266): proxy: HTTP: 
connection complete to 192.168.201.23:1109 (host1)
[Tue Jan 08 12:01:15 2008] [debug] mod_proxy_http.c(1478): proxy: start 
body send
[Tue Jan 08 12:01:15 2008] [debug] mod_proxy_http.c(1567): proxy: end body 
send
[Tue Jan 08 12:01:15 2008] [debug] proxy_util.c(1870): proxy: HTTP: has 
released connection for (host1)
[Tue Jan 08 12:01:15 2008] [debug] mod_proxy_balancer.c(41): proxy: 
BALANCER: canonicalising URL //selfcare/app/assets/css/urlkit.css
[Tue Jan 08 12:01:15 2008] [debug] mod_proxy_balancer.c(258): proxy: 
BALANCER: Found value 0000K8zpkCtCy6l9Y91Q86bETpX:-1 for stickysession 
JSESSIONID
[Tue Jan 08 12:01:15 2008] [debug] mod_proxy_balancer.c(950): proxy: 
Entering byrequests for BALANCER (balancer://selfcare)
[Tue Jan 08 12:01:15 2008] [debug] mod_proxy_balancer.c(517): proxy: 
BALANCER (balancer://selfcare) worker (http://host2:1109/selfcare) 
rewritten to http://host2:1109/selfcare/app/assets/css/urlkit.css
[Tue Jan 08 12:01:15 2008] [debug] mod_proxy.c(819): Running scheme 
balancer handler (attempt 0)
[Tue Jan 08 12:01:15 2008] [debug] mod_proxy_http.c(1693): proxy: HTTP: 
serving URL http://host2:1109/selfcare/app/assets/css/urlkit.css
[Tue Jan 08 12:01:15 2008] [debug] proxy_util.c(1852): proxy: HTTP: has 
acquired connection for (host2)
[Tue Jan 08 12:01:15 2008] [debug] proxy_util.c(1913): proxy: connecting 
http://host2:1109/selfcare/app/assets/css/urlkit.css to host2:1109
[Tue Jan 08 12:01:15 2008] [debug] proxy_util.c(2012): proxy: connected 
/selfcare/app/assets/css/urlkit.css to host2:1109
[Tue Jan 08 12:01:15 2008] [debug] proxy_util.c(2169): proxy: HTTP: fam 2 
socket created to connect to host2
[Tue Jan 08 12:01:15 2008] [debug] proxy_util.c(2266): proxy: HTTP: 
connection complete to 192.168.201.29:1109 (host2)
[Tue Jan 08 12:01:15 2008] [debug] mod_proxy_http.c(1478): proxy: start 
body send
[Tue Jan 08 12:01:15 2008] [debug] mod_proxy_http.c(1567): proxy: end body 
send


        Have I stumbled across a bug, or am I doing something wrong?  Any 
help would be greatly appreciated....


                                        Brendan
Mime
View raw message