httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hehl, Thomas" <Thomas.H...@acs-inc.com>
Subject [users@httpd] jk_mod switching URLs?
Date Thu, 24 Jan 2008 19:37:47 GMT
I have httpd running on a Redhat 3 box as a load balancer to two other
redhat servers in a tomcat 6.0 cluster. 

 

If I connect directly to one of the cluster servers, I can test my
application with no issues. When I go to the load balancer and run the same
test, I can log on and click on one link, but when I click on the second
link, it changes the URL from
http://loadserver/myapp/do/workflogMgr?flowName=personalInfo
<http://loadserver/myapp/do/workflogMgr?flowName=personalInfo>  to
http://loadserver/myapp/myapp/index.html
<http://loadserver/myapp/myapp/index.html>  and throws a 404 since
myapp/myapp isn't valid.

 

Here is the information in access_log in httpd/logs:

 

192.168.205.58 - - [14/Jan/2008:15:07:14 -0500] "GET
/myapp/do/workflowMgr?flowName=personalInfo HTTP/1.1" 404 1015
"http://lexlinux7/myapp/do/login" "Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11"

 

JKMount /myapp* myapp

 

Does anyone have any ideas as to what might be causing this issue?

 

Thanks.

Thom Hehl
Sr. eJuror Architect

* Office (859) 277-8800 x 144

* Thomas.Hehl@acs-inc.com <mailto:Thomas.Hehl@acs-inc.com>  
ACS, Inc.

Government Solutions

1733 Harrodsburg Road
Lexington, KY 40504-3617

This e-mail message, including any attachments, is for the sole use of the
intended recipient(s) and may contain confidential and privileged
information. Any unauthorized review, use, disclosure or distribution is
prohibited. If you are not the intended recipient, please contact the sender
by reply e-mail and destroy all copies of the original message and notify
sender via e-mail at Thomas.Hehl@acs-inc.com
<mailto:Thomas.Hehl@acs-inc.com>  or by telephone at 859-277-8800 ext. 144.
Thank you.

 


Mime
View raw message