httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Reeves, Michael D Civ 517 SMXS/MXDEC" <Michael.Ree...@cisf.af.mil>
Subject [users@httpd] RE: Problem with ./configure Apache 2.2.6
Date Wed, 09 Jan 2008 16:54:55 GMT
I did a little bit more playing around with this.  If I put the full
path in the bindir variable in the config.layout file (bindir:
/usr/local/apache2/bin), I still get the exact same error message.

Has anyone ever seen this before?  

Thanks greatly for any help on this
Mike



 

-----Original Message-----
From: Reeves, Michael D Civ 517 SMXS/MXDEC
[mailto:Michael.Reeves@cisf.af.mil] 
Sent: Wednesday, January 09, 2008 8:20 AM
To: users@httpd.apache.org
Subject: [users@httpd] Problem with ./configure Apache 2.2.6

Hi, I'm having a problem installing a new webserver.  I'm doing the
exact same procedure that I've used in the past (v 2.0.55, 2.0.59, and
2.2.4), but it no longer seems to be working.
 
I'm doing a custom layout. I've edited the config.layout file to match
what I'd done in the past, copying the format used in that file.
 
I'm using
prefix: /usr/local/apache2
exec_prefix: ${prefix}
bindir: ${exec_prefix}/bin
....
 
I run the configure script: 
./configure --enable-layout=myLayout .......
 
I get the following error msg:
....
configure: error: expected an absolute directory name for --bindir:
NONE:/bin configure failed for srclib/apr
 
What gives?  Is this a bug?  This worked perfectly for 2.2.4.  If this
functionality has been removed then all the stuff in config.layout will
fail.
 
 

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message