httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Covener" <cove...@gmail.com>
Subject Re: [users@httpd] AuthBasicProvider ldap dbd not failing through
Date Thu, 24 Jan 2008 20:16:18 GMT
On Jan 24, 2008 3:13 PM, paredes <paredes@aecom.yu.edu> wrote:
> Hi!
>
> Only the 1st provider hits and returns "user not found" or "password
> mismatch". The 2nd provider is never seen. I had expected to see some
> type of error related to the 2nd provider. In the case where I use
> "AuthBasicProvider ldap dbd" & provide a valid ldap user:password the
> logs show ldap correctly authenticating/authorizing. When I provide a
> valid mysql only user:password, the logs show that ldap fails but no
> other action is taken.
>
> When the arguments are reversed, and a valid mysql user:password is
> presented the logs shows a hit with mysql correctly authenticating. But
> when I provide an ldap only user:password the logs show mysql correctly
> rejecting the user but no ldap activity.
>

Can you try LDAP and File (as in htpasswd -c ...)?  This worked for me
in both directions.


-- 
Eric Covener
covener@gmail.com

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message