httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Slive" <jos...@slive.ca>
Subject Re: [users@httpd] .htaccess and hotlinking question/problem
Date Mon, 24 Dec 2007 16:01:24 GMT
On Dec 24, 2007 2:30 AM, Techman <techman@netscan.ca> wrote:
> >From what I can figure out now, mod-rewrite is not installed. Now when I
> type in www.mysite.com/download/myfile.avi in my browser I get a server
> error.  There is nothing in my httpd.conf about mod_rewrite, nor can I find
> any files pertaining to it. This serves my purpose as it does stop the
> direct downloading of files, it's just not pretty and would be nice if it
> worked properly. Just so you know where I am coming from, I did not even
> know what mod_rewite was until a few days ago. If there is another way to
> test to see if it is installed, please let me know. I am not a guru on this
> stuff, just know enough to get by.

apachectl -M
will tell you all the modules you have loaded (if you are using the
most recent version of apache; otherwise, you'll need "httpd -l" and
check all the LoadModule directives in httpd.conf).

But you don't need mod_rewrite for this. Assuming you have control of
httpd.conf, you can use something like
http://httpd.apache.org/docs/2.2/env.html#examples
or
http://wiki.apache.org/httpd/DisableImageHotLinking

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message