httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Axel-Stephane SMORGRAV" <Axel-Stephane.SMORG...@europe.adp.com>
Subject RE: [users@httpd] apachectl startssl returns "assertion 'rv == APR_SUCCESS" failed'
Date Wed, 05 Dec 2007 07:43:29 GMT
You can circumvent this problem by configuring your host to use a DNS server for name resolution,
ie. configure nsswitch.conf with "host: file dns" and have a resolv.conf with appropriate
contents.

The reason why you experience this error only on one of your servers is because one is configured
for DNS resolution, and the other not.

This is a known bug in Apache 2.0.x. I believe it was solved in Apache 2.2.x

-ascs

-----Message d'origine-----
De : mikeporter [mailto:mike@udel.edu] 
Envoyé : mercredi 5 décembre 2007 05:30
À : users@httpd.apache.org
Objet : Re: [users@httpd] apachectl startssl returns "assertion 'rv == APR_SUCCESS" failed'



I think this is caused by Apache trying to bind to an IP that does not have a PTR record or
other way to turn the IP into a name.  I ran into this a bit ago when booting a server that
has an interal IP used to communicate with its platform controller. 
This IP did not
have a name.  I temporarily solved the problem by changing from _default_ to '*', but this
not a good solution because now Apache has bound to this special IP.  I suspect this is why
the platform controller can not talk to the Solaris domain, but I'm going to wait until tomorrow
before messing with it further.

Mike

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message