httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ashraf Fouad <ash_m...@hotmail.com>
Subject [users@httpd] All requests are marked "K" keepalive in IHS 6.0.2.15 Apache 2.0.47
Date Sat, 22 Dec 2007 06:27:33 GMT

Dears,
 I'm having a problem with IHS (IBM_HTTP_Server/6.0.2.15 Apache/2.0.47) that it is marking
all threads are as KKKKKKKKKKKKKKKKKKKKKKK "K" Keepalive (read) with 0 idle workers as per
the URL http://www.ashraffouad.net/02-http-all-requests-k.jpg .
 
High level overview on the environment:

2 Juniper load balancer submit to 3 http servers
 

ALL HTTP Servers are IBM IHS 6.0.2.15 deployed on win 2003 enterprise server SP1, following
the output of command "apache –v"
Server version: IBM_HTTP_Server/6.0.2.15 Apache/2.0.47
Server built:   Aug  9 2006 14:27:54
The HTTP Servers submit requests to 3 WAS servers 6.0.2.15 with domain cluster, they are deployed
on AIX machine.
 

The 3 WAS servers are controlled by separate deployment manager, and they are connected to
different backends as WebSpshere MQ 5.3, Email Server on SUSE linux, DB2 for customer logging,
and Tivoli Directory server.
 
I'm trying to simulate the case with stress testing tool as load runner by making heavy load
but I'm not able to reproduce the problem, I'm trying to take advantage of the current vacation
before expected heavy load after vacation and the problems starts hitting again.
 Any ideas what may be the cause of the problem?
Thanks, best regards,
Ashraf Fouad Ayoub 
_________________________________________________________________
Express yourself instantly with MSN Messenger! Download today it's FREE!
http://messenger.msn.click-url.com/go/onm00200471ave/direct/01/
Mime
View raw message