httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vincent Bray" <nood...@gmail.com>
Subject Re: [users@httpd] Using SSI in proxied content
Date Wed, 05 Dec 2007 21:36:28 GMT
On 05/12/2007, Marko Asplund <marko.asplund@ixonos.com> wrote:
>
> I'm trying to setup a Apache reverse proxy to run server-side include
> commands included in proxied content.
> Apache proxies content coming from Tomcat using mod_proxy_ajp.
> SSI commands get run in local content, but not in proxied content.
> Should this sort of setup work with Apache 2.2 or is this just a problem
> with my configuration?

It should work for proxied content, assuming your config specifies the
filter correctly. Something like this should work:

LoadModule includes_module modules/mod_includes.so

# ...

<VirtualHost *:80>
 ServerName what.ever.com
 ProxyPass / http://localhost:8080/
 ProxyPassReverse / http://localhost:8080/
 AddOutputFilterByType INCLUDES text/html
 # I'm not sure if this is necessary..
 <Location />
  Options Includes
 </Location>
</VirtualHost>

-- 
noodl

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message