httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Neil A. Hillard" <neil.hill...@agustawestland.com>
Subject Re: [users@httpd] Vhost issues
Date Thu, 20 Dec 2007 08:41:32 GMT
Chris Arnold wrote:
>> Have you tried adding:
> 
>> ServerAlias www.teknerds.net
> 
>> to the second VH?  (Essentially, you need to tell Apache which VH to
>> direct the request to - www.teknerds.net is not the same as teknerds.net)
> 
> Yes, i make that change and it still takes me to the first vhost. You'll  notice the
first vhost listed is mytimewithgod.net and when anyone types in www.mytimewithgod.net, they
end up with mytimewithgod.net in the web browser address (which is fine) but when the 2nd
vhost is setup the exact way, it still takes me to the first vhost.

Essentially what you're saying is that all requests hit the first VH.
The fact is that mytimewithgod.net and www.mytimewithgod.net may be
because of this, not because of your configuration.

Does 'apachectl -t' return any errors with your config?

The problem you're experiencing appears to be that your NameVirtualHost
line doesn't tie up with your VirtualHost but from the extract you
supplied they do.

You also need to ensure that ServerName and ServerAlias define all names
that you want the VH to respond to, otherwise the first VH will get the
request.


				Neil.

-- 
Neil Hillard                    neil.hillard@agustawestland.com
AgustaWestland                  http://www.whl.co.uk/

Disclaimer: This message does not necessarily reflect the
            views of Westland Helicopters Ltd.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message