httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Neil A. Hillard" <neil.hill...@agustawestland.com>
Subject Re: [users@httpd] Vhost issues
Date Wed, 19 Dec 2007 14:07:08 GMT
Chris,

Chris Arnold wrote:
> Chris Arnold wrote:
>> Using apache 2.2.3 and at this time, we only have 2 vhosts. When trying to go to
www.teknerds.net people get the other vhost (which is MUWP). Following id the vhost file:
>> #
>> NameVirtualHost *:80
>>
>> <VirtualHost *:80>
>>     ServerAdmin administrator@mytimewithgod.net
>>     ServerName mytimewithgod.net
>>     #ServerAlias mytimewithgod.net *.mytimewithgod.net
>>
<huge snip>
>> </VirtualHost>
>>
>> <VirtualHost *:80>
>>     ServerAdmin administrator@teknerds.net
>>     ServerName teknerds.net
>>     DocumentRoot /srv/www/htdocs/sites/teknerds
<huge snip>
>> </VirtualHost>
>>
>> What do i have wrong? Thanks for any help.
> Can anyone offer any pointers as to what is wrong?

Have you tried adding:

ServerAlias www.teknerds.net

to the second VH?  (Essentially, you need to tell Apache which VH to
direct the request to - www.teknerds.net is not the same as teknerds.net)

HTH,


				Neil.

-- 
Neil Hillard                    neil.hillard@agustawestland.com
AgustaWestland                  http://www.whl.co.uk/

Disclaimer: This message does not necessarily reflect the
            views of Westland Helicopters Ltd.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message