httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Arnold <carn...@electrichendrix.com>
Subject [users@httpd] Gzip config
Date Sun, 02 Dec 2007 23:46:29 GMT
Using apache 2.2.3-16-15 and trying to implement mod_deflate. I have asked this list before
but have lost that email, so forgive me for a repeat question. We have the following structure:
<docroot>/sites/<sitename>
In loadmodule.conf i have the loadmodule line with the pth to the .so file and in /etc/apache2/default-server.conf
i have:
 # Insert filter
SetOutputFilter DEFLATE

# Netscape 4.x has some problems...
BrowserMatch ^Mozilla/4 gzip-only-text/html

# Netscape 4.06-4.08 have some more problems
BrowserMatch ^Mozilla/4\.0[678] no-gzip

# MSIE masquerades as Netscape, but it is fine
# BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

# NOTE: Due to a bug in mod_setenvif up to Apache 2.0.48
# the above regex won't work. You can use the following
# workaround to get the desired effect:
BrowserMatch \bMSI[E] !no-gzip !gzip-only-text/html

# Don't compress images
SetEnvIfNoCase Request_URI \
\.(?:gif|jpe?g|png)$ no-gzip dont-vary

# Make sure proxies don't deliver the wrong content
Header append Vary User-Agent env=!dont-vary

(is all of the above in the right place (file and location))?
Under the <directory> directive (following http://httpd.apache.org/docs/2.0/mod/mod_deflate.html).
I go to a site to see if i have compression and the site says "no" compression. What did i
leave out to get this working? Site link is http://www.mytimewithgod.net

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message