httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Axel-Stephane SMORGRAV" <Axel-Stephane.SMORG...@europe.adp.com>
Subject RE: [users@httpd] Enquiry about Reserve Proxy
Date Tue, 11 Dec 2007 07:23:43 GMT
The logs you sent show that every thing works perfectly. The access log shows two requests
both returning HTTP 200 OK. The debug log shows that your RP connects to the content server
and returns a body.

Do you happen to have any entry in your access log indicating that a HTTP 404 "File not found"
was returned? If not you will need to look for the problem elsewhere.


-ascs
 
-----Message d'origine-----
De : pdt_p [mailto:pinlie@gmail.com] 
Envoyé : mardi 11 décembre 2007 04:29
À : users@httpd.apache.org
Objet : RE: [users@httpd] Enquiry about Reserve Proxy


Hi...

I have set "ProxyHTMLExtended On" but seems like the problem still occur.
I set LogLevel to debug and "ProxyHTMLLogVerbose On", the image that my
browser request is return HTTP code 200. this is the access log file:
127.0.0.1 - - [11/Dec/2007:10:21:36 +1100] "GET / HTTP/1.1" 200 3026
127.0.0.1 - - [11/Dec/2007:10:21:36 +1100] "GET /myLogo.jpg HTTP/1.1" 200
3265

log in error log is
[Tue Dec 11 10:21:36 2007] [debug] proxy_util.c(1870): proxy: HTTP: has
released connection for (147.76.10.23)
[Tue Dec 11 10:21:36 2007] [debug] mod_proxy_http.c(54): proxy: HTTP:
canonicalising URL //147.76.10.23/nec_logo.jpg
[Tue Dec 11 10:21:36 2007] [debug] proxy_util.c(1412): [client 127.0.0.1]
proxy: http: found worker http://147.76.10.23/ for
http://147.76.10.23/nec_logo.jpg, referer: http://localhost/
[Tue Dec 11 10:21:36 2007] [debug] mod_proxy.c(819): Running scheme http
handler (attempt 0)
[Tue Dec 11 10:21:36 2007] [debug] mod_proxy_http.c(1693): proxy: HTTP:
serving URL http://147.76.10.23/nec_logo.jpg
[Tue Dec 11 10:21:36 2007] [debug] proxy_util.c(1852): proxy: HTTP: has
acquired connection for (147.76.10.23)
[Tue Dec 11 10:21:36 2007] [debug] proxy_util.c(1913): proxy: connecting
http://147.76.10.23/nec_logo.jpg to 147.76.10.23:80
[Tue Dec 11 10:21:36 2007] [debug] proxy_util.c(2012): proxy: connected
/nec_logo.jpg to 147.76.10.23:80
[Tue Dec 11 10:21:36 2007] [debug] proxy_util.c(2169): proxy: HTTP: fam 2
socket created to connect to 147.76.10.23
[Tue Dec 11 10:21:36 2007] [debug] proxy_util.c(2266): proxy: HTTP:
connection complete to 147.76.10.23:80 (147.76.10.23)
[Tue Dec 11 10:21:36 2007] [debug] mod_proxy_http.c(1478): proxy: start body
send
[Tue Dec 11 10:21:36 2007] [info] [client 127.0.0.1] Non-HTML content; not
inserting proxy-html filter, referer: http://localhost/
[Tue Dec 11 10:21:36 2007] [debug] mod_proxy_http.c(1567): proxy: end body
send
[Tue Dec 11 10:21:36 2007] [debug] proxy_util.c(1870): proxy: HTTP: has
released connection for (147.76.10.23)

one thing that i relise, any gif images can be rendered properly but not for
jpeg image. any idea?

Thank you

Pdt







Axel-Stephane  SMORGRAV-2 wrote:
> 
> AS far as I can tell from the looks of your configuration, you are pretty
> much on top of things.
> 
> What you need to do is investigate the cause for the missing resources,
> for example by looking at the access- and  errorlogs to see what URLs are
> requested that return a HTTP 404. There may be URLs that you expected to
> be rewritten by one of your ProxyHTMLURLMap rules but that were not. You
> may have to set "ProxyHTMLExtended On" for these links to be rewritten if
> they are included in for example JavaScript or CSS.
> 
> 
> -ascs
>  
> -----Message d'origine-----
> De : pdt_p [mailto:pinlie@gmail.com] 
> Envoyé : lundi 10 décembre 2007 13:37
> À : users@httpd.apache.org
> Objet : [users@httpd] Enquiry about Reserve Proxy
> 
> 
> Hi....
> 
> I have setup a reserve proxy in my working environment. 
> I use Apache 2.2.6 and mod_proxy_html 3.0.0. I run this on windows xp.
> I do have a webserver running on difference subnet. I try to put the
> reserve
> proxy for that webserver(the one on difference subnet).
> I have follow the tutorial in this website :
> http://www.apachetutor.org/admin/reverseproxies
> I am able to render the page through the proxy but some images and css is
> missing. seems like the path is not right.
> this is my setting:
> 
> 
> <IfModule mod_proxy.c>
>     ProxyRequests Off
> 
>     <Proxy *>
>         Order deny,allow
>         Allow from all
>     </Proxy>
> ProxyHTMLLogVerbose On
> 
> ProxyPass / http://147.76.10.23/
> ProxyPass /sss/ http://147.76.10.23/ss/
> ProxyPass /ssss/ http://147.76.10.23/ss/ssss/
> 
> 
> ProxyHTMLURLMap http://147.76.10.23/ /
> ProxyHTMLURLMap http://147.76.10.23/ss /ss
> ProxyHTMLURLMap http://147.76.10.23/ssss /ssss
> 
> <Location />
>         ProxyPassReverse /
>         SetOutputFilter  proxy-html
>         ProxyHTMLURLMap  /      /
> 		RequestHeader    unset  Accept-Encoding
> </Location>
> <Location /ss/>
>         ProxyPassReverse /
>         SetOutputFilter  proxy-html
>         ProxyHTMLURLMap  /      /ss/
>         ProxyHTMLURLMap  /ss      /ss
>         ProxyHTMLURLMap  /ss/      /ss/
> 		RequestHeader    unset  Accept-Encoding
> </Location>
> 	
> <Location /ssss/>
>         ProxyPassReverse /
>         SetOutputFilter  proxy-html
>         ProxyHTMLURLMap  /      /ssss/
>         ProxyHTMLURLMap  /ssss      /ssss
>         ProxyHTMLURLMap  /ssss/      /ssss
> 		RequestHeader    unset  Accept-Encoding
> </Location>
> </IfModule>
> 
> * Any Idea why some images and css is missing and some is working properly
> (can be loaded as what I expected)? is there any settings that I miss? 
>   since the page that I request is containing a frame, is that any setting
> is required since some frame source is in the same level as root,ex:
> http://147.76.10.23/mysource1.html, and some source come from the lower
> level, ex: http://147.76.10.23/ss/mysecondsource.html?
> 
> * The other issue is, when I request this page thrugh IE, The page can be
> rendered but If i request it thorugh FireFox, the HTML code is display.
> any
> idea?
> 
> * If I modify  : 
>     - "ProxyPass / http://147.76.10.23/"  to "ProxyPass /app1/
> http://147.76.10.23/" 
>     - "ProxyHTMLURLMap http://147.76.10.23/ /" to "ProxyHTMLURLMap
> http://147.76.10.23/ /app1"
>     -  " <Location />
>               ProxyPassReverse /
>               SetOutputFilter  proxy-html
>               ProxyHTMLURLMap  /      /
>               RequestHeader    unset  Accept-Encoding
>           </Location>
>         " to "
>            <Location /app1/>
>                 ProxyPassReverse / 
>                 SetOutputFilter  proxy-html
>                 ProxyHTMLURLMap  /      /app1/
>                 ProxyHTMLURLMap  /app1  /app1
>                 RequestHeader    unset  Accept-Encoding
>            </Location>
>        " 
>    So when I request in the web browser the url change from
> http://hostname/
> to http://hostname/app1/ 
>    By doing this what is render in the web browser is all the css and
> image
> link is not found? any idea?
> 
> 
> Thank you very much in advance.
> 
> 
> 
> Pdt
> 
> 
> 
>  
> -- 
> View this message in context:
> http://www.nabble.com/Enquiry-about-Reserve-Proxy-tp14252046p14252046.html
> Sent from the Apache HTTP Server - Users mailing list archive at
> Nabble.com.
> 
> 
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
> 
> 
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Enquiry-about-Reserve-Proxy-tp14252046p14267102.html
Sent from the Apache HTTP Server - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message