httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rocco Scappatura" <Rocco.Scappat...@sttspa.it>
Subject [users@httpd] Reverse proxy all but something
Date Sat, 08 Dec 2007 20:22:58 GMT

Hello,

I have reverse proxied the url '/' (and so all that starring by '/').

<IfModule mod_proxy.c>
	ProxyRequests off
	ProxyPass / http://10.1.1.1/smthing/
	ProxyPassReverse / http://10.1.1.1/smthing/
</IfModule>

Now I would like to install a log analyzer (awstats) for analyzing the
access to my website.

I have followed the instructions fro awstats README. But, When I try to
access to the URL of awstats on my web site:

http://www.example.com/awstats/

The request is proxied to http://10.1.1.1/smthing/awstats/

Getting a 'Page not found' response, of course.

I have tried to move:

		Alias /awstatsclasses "C:/Programmi/AWStats/wwwroot/classes/"
		Alias /awstatscss "C:/Programmi/AWStats/wwwroot/css/"
		Alias /awstatsicons "C:/Programmi/AWStats/wwwroot/icon/"
		ScriptAlias /awstats/ "C:/Programmi/AWStats/wwwroot/cgi-bin/"

Above and below of the Proxy* directives, but nothing ahas changed.

How could I solve this issue?

rocsca



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message