httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Duncan Brannen <...@st-andrews.ac.uk>
Subject Re: [users@httpd] Problem with NameVirtualHost and VirtualHost
Date Tue, 20 Nov 2007 15:38:26 GMT


You can't use Virtual Hosts like that with SSL.  The SSL handshake
with keys etc comes before the client tells the server which host it's 
trying
to connect to, so the server has to read the ssl config before then, 
thus you
get the config for the first one.

Solution is to use IP based virtual hosts, though you might be able to do
something with server side includes and redirects that changed the home
page based on th %{HTTP_HOST} variable.  I've done something like
that when i wanted https://virtualhost2 to redirect to 
https://virtualhost1/host2


Help Any?

    Duncan



Gregor Schneider wrote:
> Hi Guys,
>
> I always keep being puzzled about those options, and I also don't get
> enlighted by the doc.
>
> this is what I have:
>
> System: Debian Etch
>
> /etc/apache2/apaxhe2.conf:
>
> ...
> NameVirtualHost *:80
> NameVirtualHost *:443
> ...
>
> in /etc/apache2/sites-enabled I have
>
> file clue:
>
> <VirtualHost *:80>
>     ServerName test-clue
>     ....
> </VirtualHost>
> <VirtualHost *:443>
>     ServerName test-clue
>     ....
> </VirtualHost>
>
> file dom:
>
> <VirtualHost *:80>
>     ServerName test-dom
>     ....
> </VirtualHost>
> <VirtualHost *:443>
>     ServerName test-dom
>     ....
> </VirtualHost>
>
> file ltc:
>
> <VirtualHost *:80>
>     ServerName test-ltc
>     ....
> </VirtualHost>
> <VirtualHost *:443>
>     ServerName test-ltc
>     ....
> </VirtualHost>
>
> Since I'm running the test-server on one single IP, I'm aware that I'm
> getting ssl-warnings - it doesn't matter.
>
> However, this is what's driving me nuts:
>
> When I enter the url "https://test-ltc", I'm always sent to
> "https://test-clue", and I kust don't understand why.
>
> According to the docs
> (http://httpd.apache.org/docs/2.2/de/vhosts/examples.html) my example
> doesn't look all that wrong.
>
> Is there anything I'm overlooking?
>
> This is my /etc/hosts:
>
> 10.170.202.5    test-clue
> 10.170.202.5    test-ltc
> 10.170.202.5    test-ltc-kr
> 10.170.202.5    test-dom
>
> Could somebody please shed some light here?
>
> TIA
>
> Gregor
>   


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message