httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Preetam Palwe" <preet...@aftek.com>
Subject [users@httpd] RE: Apache + DEFLATE : Does not work
Date Tue, 06 Nov 2007 15:50:31 GMT
To add one more thing 
I tested this with mozilla and firebug from outside my organization (from my
home) and to my surprise it working. I am able to see the reduced size java
script (7K instead of 29K)
But it still not working from inside my organization. Am I behind any proxy?
 
Thanks Again.
~Preetam

  _____  

From: Preetam Palwe [mailto:preetamp@aftek.com] 
Sent: Tuesday, November 06, 2007 9:04 PM
To: users@httpd.apache.org
Cc: preetam palwe
Subject: Apache + DEFLATE : Does not work


Hello 
    We have Apache serving our static contents and Jboss to serve the
dynamic data / transactions. 
We have changed configuration in Apache so that I can use html/xml/java
script compression using mod_deflate. 
But the problem is I am not able to receive compressed contents in browser.
I have verified this in mozilla (2.0.0.9) using Firebug addon. 
Can you please help me in this. 


    Here is the sample configuration 


<VirtualHost X.Y.Z.W:80> 
     ServerAdmin preet
<http://groups.google.com/groups/unlock?msg=1f10ed2e254930c0&_done=/group/co
mp.infosystems.www.servers.unix/browse_thread/thread/966bfbc71df9fc65/1f10ed
2e254930c0> ...@aftek.com 
     DocumentRoot
"/usr/java/jboss-4.0.3SP1/server/default/deploy/sample.ear/sample.war" 
    ServerName sample.aftek.com 


     ErrorLog logs/sample-error_log 
     TransferLog logs/sample-access_log 


     JkOptions     +ForwardKeySize +ForwardURICompat -ForwardDirectories 


 JkMount /sample worker1 
 JkMount /sample/* worker1 


 JkUnMount /sample/images/* worker1 
 JkUnMount /sample/css/* worker1 
 JkUnMount /sample/js/* worker1 


 DeflateFilterNote Input instream 
 DeflateFilterNote Output outstream 
 DeflateFilterNote Ratio ratio 


 LogFormat '"%r" %{outstream}n/%{instream}n (%{ratio}n%%) "%{User- agent}i"'
deflate 
 CustomLog logs/deflate_log deflate 


 <Location /sample> 
  AddOutputFilterByType DEFLATE text/html 
  AddOutputFilterByType DEFLATE text/xml 
  AddOutputFilterByType DEFLATE text/css 
  AddOutputFilterByType DEFLATE text/javascript 
  AddOutputFilterByType DEFLATE application/x-javascript 
 </Location> 
</VirtualHost> 


Version Info 
Jboss:             jboss-4.0.3SP1 
Apache:          httpd-2.0.52-28 
Mod_jk:           mod_jk-1.2.15-1 


Also 
    I suspect there is something going wrong in response headers : 
"Vary : Accept-Encoding" 


Thanks for help in advance. 


Thanks & Best Regards 
~Preetam 


Mime
View raw message