httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Danie Qian" <dan...@bestningning.com>
Subject Re: [users@httpd] dbd mysql segmentation fault in 2.2.6
Date Tue, 20 Nov 2007 21:50:21 GMT

----- Original Message ----- 
From: "Daniel Campbell" <campbell@on2.com>
To: <users@httpd.apache.org>
Sent: Tuesday, November 20, 2007 4:34 PM
Subject: Re: [users@httpd] dbd mysql segmentation fault in 2.2.6


> My ldd looks like
> linux-gate.so.1 => (0xffffe000)
> libaprutil-1.so.0 => /usr/lib/libaprutil-1.so.0 (0xb7fbf000)
> libldap-2.3.so.0 => /usr/lib/libldap-2.3.so.0 (0xb7f8c000)
> libsasl2.so.2 => /usr/lib/libsasl2.so.2 (0xb7f75000)
> libresolv.so.2 => /lib/libresolv.so.2 (0xb7f62000)
> liblber-2.3.so.0 => /usr/lib/liblber-2.3.so.0 (0xb7f56000)
> libmysqlclient_r.so.15 => /usr/lib/libmysqlclient_r.so.15 (0xb7e10000)
> libnsl.so.1 => /lib/libnsl.so.1 (0xb7df9000)
> libm.so.6 => /lib/libm.so.6 (0xb7dd2000)
> libz.so.1 => /usr/lib/libz.so.1 (0xb7dbe000)
> libssl.so.0.9.8 => /usr/lib/libssl.so.0.9.8 (0xb7d81000)
> libcrypto.so.0.9.8 => /usr/lib/libcrypto.so.0.9.8 (0xb7c55000)
> libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb7c35000)
> libapr-1.so.0 => /usr/lib/libapr-1.so.0 (0xb7c13000)
> libuuid.so.1 => /lib/libuuid.so.1 (0xb7c10000)
> librt.so.1 => /lib/librt.so.1 (0xb7c08000)
> libcrypt.so.1 => /lib/libcrypt.so.1 (0xb7bda000)
> libpthread.so.0 => /lib/libpthread.so.0 (0xb7bc2000)
> libdl.so.2 => /lib/libdl.so.2 (0xb7bbe000)
> libc.so.6 => /lib/libc.so.6 (0xb7a7c000)
> /lib/ld-linux.so.2 (0xb7fdd000)
>
> Can you supply a copy of yours for comparison?
>
[root@stp-fe09 bin]# ldd httpd
        libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0x0093c000)
        libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0x00c8f000)
        libcom_err.so.2 => /lib/libcom_err.so.2 (0x0077b000)
        libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0x00919000)
        libresolv.so.2 => /lib/libresolv.so.2 (0x00976000)
        libaprutil-1.so.0 => /usr/local/apr/lib/libaprutil-1.so.0 
(0x00cfa000)
        libssl.so.4 => /lib/libssl.so.4 (0x00aa0000)
        libcrypto.so.4 => /lib/libcrypto.so.4 (0x009b5000)
        libmysqlclient_r.so.15 => 
/usr/local/mysql/lib/mysql/libmysqlclient_r.so.15 (0x00ee9000)
        libnsl.so.1 => /lib/libnsl.so.1 (0x008ed000)
        libm.so.6 => /lib/tls/libm.so.6 (0x0072f000)
        libz.so.1 => /usr/lib/libz.so.1 (0x00754000)
        libmysqlclient_r.so.14 => /usr/lib/mysql/libmysqlclient_r.so.14 
(0x00111000)
        libexpat.so.0 => /usr/lib/libexpat.so.0 (0x00957000)
        libapr-1.so.0 => /usr/local/apr/lib/libapr-1.so.0 (0x00442000)
        libuuid.so.1 => /lib/libuuid.so.1 (0x00249000)
        librt.so.1 => /lib/tls/librt.so.1 (0x008bd000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x0024c000)
        libpthread.so.0 => /lib/tls/libpthread.so.0 (0x00905000)
        libdl.so.2 => /lib/libdl.so.2 (0x00729000)
        libc.so.6 => /lib/tls/libc.so.6 (0x0078f000)
        /lib/ld-linux.so.2 (0x0070f000)

note I am using mysql-5.0 for dbd.  libmysqlclient_r.so.14 is from the 
pre-installed OS rpm packages that got linked automatically and you dont 
need it.

[root@stp-fe09 lib]# ldd libaprutil-1.so.0.2.9
        libz.so.1 => /usr/lib/libz.so.1 (0x002c7000)
        libnsl.so.1 => /lib/libnsl.so.1 (0x00111000)
        libm.so.6 => /lib/tls/libm.so.6 (0x00e94000)
        libssl.so.4 => /lib/libssl.so.4 (0x00a68000)
        libcrypto.so.4 => /lib/libcrypto.so.4 (0x00b58000)
        libmysqlclient_r.so.15 => 
/usr/local/mysql/lib/mysql/libmysqlclient_r.so.15 (0x00127000)
        libexpat.so.0 => /usr/lib/libexpat.so.0 (0x00188000)
        libapr-1.so.0 => /usr/local/apr/lib/libapr-1.so.0 (0x001a7000)
        libuuid.so.1 => /lib/libuuid.so.1 (0x0066c000)
        librt.so.1 => /lib/tls/librt.so.1 (0x002fd000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x00faf000)
        libpthread.so.0 => /lib/tls/libpthread.so.0 (0x00820000)
        libdl.so.2 => /lib/libdl.so.2 (0x001c8000)
        libc.so.6 => /lib/tls/libc.so.6 (0x00ca8000)
        /lib/ld-linux.so.2 (0x0070f000)
        libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0x009b8000)
        libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0x001cc000)
        libcom_err.so.2 => /lib/libcom_err.so.2 (0x00b18000)
        libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0x00546000)
        libresolv.so.2 => /lib/libresolv.so.2 (0x008ec000) 


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message