httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Slive" <jos...@slive.ca>
Subject Re: [users@httpd] Vhost not working
Date Wed, 10 Oct 2007 02:30:03 GMT
On 10/9/07, Chris Arnold <carnold@electrichendrix.com> wrote:
> I am running apache 2.2.6 on sles10 sp1. We have like 3 vhost and one of those i can
not, for the life of me, getting it working. The vhost should be accessible from demo.mytimewithgod.net
but this will always send you to mytimewithgod.net. Here is the snipit from vhost file:
>

Below is what your server is sending back when you request
demo.mytimewithgod.net.

The interesting thing to note is that this is a redirect created by
php. So it seems like the request is indeed reaching the appropriate
vhost, but you have some scripts on that vhost that are redirecting
requests to www.mytimewithgod.net. Fix those scripts and I bet your
problem goes away.

HTTP/1.1 301 Moved Permanently
Date: Wed, 10 Oct 2007 02:25:49 GMT
Server: Apache/2.2.6 (Linux/SUSE)
X-Powered-By: PHP/5.1.2
Set-Cookie: PHPSESSID=bvf4ll1cicih2aip5rr564s3v5; path=/
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
X-Pingback: http://www.mytimewithgod.net/demo/xmlrpc.php
Location: http://www.mytimewithgod.net/
Vary: Accept-Encoding
Content-Length: 0
Content-Type: text/html; charset=UTF-8

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message