httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Slive" <jos...@slive.ca>
Subject Re: [users@httpd] Apache 2.2.6 and CGI problem redux
Date Wed, 03 Oct 2007 18:48:12 GMT
On 10/3/07, Apache@aandd.org <Apache@aandd.org> wrote:
> Not a total solution but getting there.
>
> Joshua Slive had some of the answer.
> He enlightened me that I was using SSI and told me to used SetOutputFilter
> and I read-up on the SSI howto.
>
> So I can include JavaScript files and they work nicely. However perl
> scripts in the cgi-bin directly stubbornly refuse to fire unless called by
> an HREF tag.
>
> The config is simple:
>
> ScriptAlias /cgi-bin/ "/usr/local/www/cgi-bin/"
> Alias /javascript/ "/usr/local/www/javascript/"
> AddHandler cgi-script .cgi .pl

You missed one little part of my suggestion: "the directory where the HTML pages
lives has "Options Includes" ".

It is the html file that needs SSI, so you need to activate the
Includes option and the INCLUDES filter for that directory, not for
the cgi-bin directory.

Also, I told you to use #include virtual, not #exec virtual. The
latter doesn't exist, as far as I know.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message