httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stusynski, Dan" <dstusyn...@ptc.com>
Subject RE: [users@httpd] Windows compile of Apache 2.0.61 with SSL fails...
Date Thu, 18 Oct 2007 18:58:58 GMT
Bill, 

Thanks for the reply.

Essentially, yes, the instructions were followed, albeit, using the ms
scripts. Actual OpenSSL buld steps:
perl Configure VC-WIN32
ms\do_nasm
nmake -f ms\ntdll.mak

Everything compiles and running ms\test results in a succesful handshake
and 0 errors. Placing the openssl directory in apache_src\scrlib still
yields the same build error when compiling 2.0.61 though.

Interestingly enough, using the exact same steps and building against
2.0.59 works fine.

I'll attempt an OpenSSL build without using the ms scripts (use the perl
scripts as the site suggests) and see if that alleviates the issue.

Dan

-----Original Message-----
From: William A. Rowe, Jr. [mailto:wrowe@rowe-clan.net] 
Sent: Thursday, October 18, 2007 12:45 PM
To: users@httpd.apache.org
Subject: Re: [users@httpd] Windows compile of Apache 2.0.61 with SSL
fails...

Stusynski, Dan wrote:
> I tried compiling Apache 2.0.61 on Windows with ZLIB and SSL and the 
> build fails.
>  
> I receive the following error:
>  
>  cd modules\ssl
>  NMAKE  -f mod_ssl.mak CFG="mod_ssl - Win32 Release" RECURSE=0 
> .\Release\mod_ssl.so
> Microsoft (R) Program Maintenance Utility   Version 6.00.8168.0
> Copyright (C) Microsoft Corp 1988-1998. All rights reserved.
>  if not exist ".\Release/" mkdir ".\Release"
> NMAKE : fatal error U1073: don't know how to make 
> '"..\..\srclib\openssl\inc32\openssl\fips.h"'

> I noted that the file "..\..\srclib\openssl\inc32\openssl\fips.h" does

> not seem to exist in my openSSL build. I also proceeded to build 
> without ZLIB merely to rule out any issue it could be causing and the 
> build still fails with the above error.

Right :)

Back to your openssl build with you, did you follow the instructions at

http://httpd.apache.org/docs/2.2/platform/win_compiling.html

perl Configure no-mdc2 no-rc5 no-idea enable-zlib VC-WIN32
-Ipath/to/srclib/zlib ms\do_masm.bat nmake -f ms\ntdll.mak

I am guessing you didn't run openssl Configure and one of it's methods
are still pointing at fips-stuff.  Also note this tree;

http://www.apache.org/dist/httpd/binaries/win32/patches_applied/

has a patch we applied for both, although I'm working to mop those up a
bit so there are fewer changes.

Bill

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server
Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message