httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ian Dobson" <...@plus.ca>
Subject [users@httpd] Error Reading from remote server
Date Wed, 24 Oct 2007 15:17:59 GMT
Hi, I'm trying to get reverse proxy working so I can move our webservers all to 1 IP address.
 The problem I'm seeing is this.

Proxy Error
The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /crm/eware.dll/go. 
Reason: Error reading from remote server
________________________________________
Apache/2.2.3 (Scientific Linux) Server



It is very intermittent, sometimes it will work perfectly and other times I get the error
right away, if I refresh a few times it will start to work, and as long as I keep clicking
it will continue to work until I walk away for a few minutes, then the problem is back.

If I bypass the proxy it works perfectly.


This is what I have in httpd.conf
I have 3 sections all pretty much identical except for the server names

<VirtualHost *:80>
  ServerName outside.domain.com
  ServerAlias outside.domain.com
  ProxyRequests Off
  <Proxy>
    Order deny,allow
    Allow from all
  </Proxy>
  ProxyPreserveHost   on
  ProxyPass           /   http:// inside.domain.com /
  ProxyPassReverse    /   http:// inside.domain.com /

</VirtualHost>

Outside.domain.com is in DNS and inside.domain.com is in the hosts file on the proxy.

Does anyone have any ideas?  My apache version os 2.2.3
Thanks.




---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message