httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: [users@httpd] problem starting apache with mod_ssl.so
Date Tue, 09 Oct 2007 19:20:33 GMT
Tom Hart wrote:
> Hello again everybody. Now that my apache server is successfully
> authenticating with ldap, I'd like to add in ssl support. Using the
> instructions at http://www.neilstuff.com/apache/apache2-ssl-windows.htm
> I was able to get it pretty close, and work through the "spaces in file
> names" errors and stuff like that. Now that I seem to have it all set up
> correctly, httpd.exe crashes every time I try to start it.

I presume you used the mod_ssl.so and ssleay32.dll/libeay32.dll from
the same package as you installed httpd.

> Faulting application httpd.exe, version 2.2.4.0, faulting module
> mod_ssl.so, version 2.2.3.0, fault address 0x0000eebd.

That's not particularly helpful (obviously :)  Please see
http://httpd.apache.org/dev/debugging.html  and
http://www.apache.org/dist/httpd/binaries/win32/#source

about obtaining the .pdb files (-symbols.zip) and providing us a stack
trace that might point the finger at what crashed.

> My apache ver is 2.2.4 and my mod_ssl.so ver is 2.2.3, (any problems
> with that? and if so where can I find a win32 compiled version of
> mod_ssl 2.2.4). I used OpenSSL 0.9.8d to create the certificates.

I'm going to check for any packaging errors that would lead to the wrong
ssl version number in the package.  Again, hopefully you didn't mix and
match packages, that's badness.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message