httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Max Dittrich <max.dittr...@t-online.de>
Subject Re: [users@httpd] httpd 2.2.6: DBD: No driver for mysql
Date Thu, 04 Oct 2007 22:25:48 GMT
Hi,

Sheryl schrieb:
> Greetings,
> 
> I just tried to compile apache 2.2.6 using the same configuration options
> I used on apache 2.2.4.  But when I try to start it up I get this error
> 
> DBD: No driver for mysql
> 
> The line it's complaining about in the conf file is
> 
> DBDriver mysql
> 
> When I look in srclib/apr-util/dbd  I see these files in 2.2.6
> 
> apr_dbd.c          apr_dbd_sqlite3.c  NWGNUdbdsqli2
> apr_dbd_pgsql.c    NWGNUdbdmysql      NWGNUdbdsqli3
> apr_dbd_sqlite2.c  NWGNUdbdpgsql      NWGNUmakefile

The support for MySQL (apr_dbd_mysql.c) isn't included in the current 
release of apr-util. To build with MySQL-support you have to follow the 
instructions given in "srclib/apr-util/INSTALL.MySQL".


.max

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message