httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Kew <n...@webthing.com>
Subject Re: [users@httpd] SetEnvIf & SESSION_USE_TRANS_SID=0
Date Tue, 23 Oct 2007 13:30:15 GMT
On Mon, 22 Oct 2007 12:39:13 +0200
Sylvain Viollat <mailing@rtcw.com.fr> wrote:

> 
> Hello!
> 
> first at all, I'm sorry for my english, I'll do my best :-)
> 
> We have a website which works with session.use_trans_sid set to On.
> Everything works just fine, but when googlebot comes on the website
> and does its job, it's also getting the php's session id in the URL.
> I've search a lot about this problem and one of the solution which
> could do what I want, disabling session.use_trans_sid if User-Agent
> is ^googlebot, doesn't work.

Faffing about with User-Agent is always wrong.

Just a thought: what happens if you use the session crap as you
are, but also generate a Content-Location header without it
in each response?  Is google smart enough to work with that?


-- 
Nick Kew

Application Development with Apache - the Apache Modules Book
http://www.apachetutor.org/

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message