httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Axel-Stéphane SMORGRAV <Axel-Stephane.SMORG...@europe.adp.com>
Subject RE: [users@httpd] Apache error
Date Thu, 27 Sep 2007 06:58:02 GMT
Lalit,
 
Your WebSphere plugin XML configuration file probably does not contain any configuration for
port 9191. You need to add *:9191 to the list of addresses on which the plugin will intercept
requests.  You do that by adding a VirtualHost to the appropriate VirtualHostGroup in the
plugin configuration:

<VirtualHostGroup Name="default_host">
	<VirtualHost Name="*:80"/>
	<VirtualHost Name="*:9191"/>
</VirtualHostGroup>

There are a couple of ways you can do that. You can change your WebSphere configuration, re-generate
the XML file and deploy it into the right location, or you can edit the XML manually.

You can find more information about configuring the plugin at http://www.redbooks.ibm.com/redpapers/pdfs/redp4045.pdf


My advice would however be NOT to use the WebSphere plugin unless you have a very good reason
to do so. You would be better off just configuring your Apache server as a reverse proxy using
mod_proxy/ProxyPass, and if you need load balancing/failover, either use a HW load balancer
or Apache 2.2...

 
-ascs

________________________________

De : Lalit Kapoor [mailto:lalitp111@gmail.com] 
Envoyé : mardi 25 septembre 2007 21:21
À : users@httpd.apache.org
Objet : [users@httpd] Apache error


Hi,

I am new to apache.

Can you suggest some solution for this problem.

I have an application on IBM Websphere application server and at the same time I installed
websphere plugin for apache as well.

I am accessing one application on port 80 which is working fine.

2nd Instance of apache is installed at port 9191, which is giving issues. Now when i am trying
to access application on port 9191. 

for e.g .  http://aoxz1006.wholespectrum.com:9191/myemp

It says " 404 page not found ".

I can see some errors in error_log: 

[Tue Sep 25 21:28:33 2007] [error] [client 10.65.165.13] File does not exist: /usr/local/apache2/htdocs/myemp
[Wed Sep 26 15:39:13 2007] [error] [client 10.65.165.13] File does not exist: /usr/local/apache2/htdocs/myemp
[Wed Sep 26 15:51:27 2007] [error] [client 10.65.165.13] File does not exist: /usr/local/apache2/htdocs/hello
[Wed Sep 26 15:52:32 2007] [error] [client 10.65.165.13] File does not exist: /usr/local/apache2/htdocs/snoop

Apache version: 2.0.52
DocumentRoot "/usr/local/apache2/htdocs" 

Any thoughts ?

Thanks,
Lalit 


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message