httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vincent Bray" <nood...@gmail.com>
Subject Re: [users@httpd] building httpd 2.2.4 for PPC on Intel Mac
Date Fri, 14 Sep 2007 11:39:17 GMT
On 14/09/2007, zdbwo@dartmouth.edu <zdbwo@dartmouth.edu> wrote:
> but when I try "sudo apachectl start", I get no httpd processes, and
> this message in my error log:
>
>
>         "[emerg] (14)Bad address: Couldn't set permissions on
>         cross-process lock; check User and Group directives"
>
> The default User and Group directives use daemon. I tried creating my
> own user account and plugging in that user/group in place of daemon,
> but I get the same result.

I've never seen this error message before. Grepping the code shows
that it's related to an inability to create the accept lock. As a
guess then, does changing the value of AcceptMutex make any
difference?

http://httpd.apache.org/docs/2.2/mod/mpm_common.html#acceptmutex

-- 
noodl

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message