httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matteo Vadagnini <mvadagn...@h-care.it>
Subject Re: [users@httpd] Apache 2.0 on windows via NFS
Date Wed, 26 Sep 2007 13:51:26 GMT
It is a permission problem.
The only way that I found working is making apache running as a service 
connected as administrator and mounting the nfs volume mapping administrator 
to root.
I hate this solution.
Does anybody know a better way to do this?
I tried to make apache running as a common user and mounting the nfs volume 
mapping that user to root, but i get an 403 (permission denied).

Mat

Alle 09:31, mercoledì 26 settembre 2007, Matteo Vadagnini ha scritto:
> Dear user list.
> I am trying to get apache 2.0.52 working on windows 2003 ES with a vhost
> that has the documentRoot on an NFS share (that is on a Solaris 9 server)
> mounted through SFU (Services For Unix) 3.5.
> The mount is Z:\ that points to the share 10.10.37.20:mnt/ramdisk_1
> I can read, write and delete files on the share.
> There is a folder "test" in the share and I can read, write and delete
> files in it.
> It seems that apache doesn't find the folder. I tried the following:
>
> -alias+Directory directive or alias+mount+Directory directive:
>
> alias /load_test "\\10.10.37.20\mnt\ramdisk_1\test"
> <Directory \\10.10.37.20\mnt\ramdisk_1\test>
> 	Options Indexes
> </Directory>
>
> alias /load_test "Z:/test"
> <Directory Z:/test>
> 	Options Indexes
> </Directory>
>
> It doesn't start at all. If I comment the Directory section, apache starts
> but http://..../load_test gives me an 404 error
>
> -vHost with the documentroot on the mounted share
> <VirtualHost *:8081>
> 	DocumentRoot "Z:\test"
>     ServerName ginepro.h-farm.it
>     ErrorLog logs/nfs-error_log
>     CustomLog logs/nfs-access_log common
>     	Options Indexes
> </VirtualHost>
>
> -vHost with the documentroot on the share URL
> <VirtualHost *:8081>
> 	DocumentRoot "\\10.10.37.20\mnt\ramdisk_1\test"
>     ServerName ginepro.h-farm.it
>     ErrorLog logs/nfs-error_log
>     CustomLog logs/nfs-access_log common
>     	Options Indexes
> </VirtualHost>
>
> apache starts but giving me again a 404 error.
> I tried mounting the share both TCP and UDP. No way. It doesn't work
>
> any help will be very appreciated, thanks
> Mat
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message