httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hatem" <timo-jaka...@telus.net>
Subject [users@httpd] Apache works in one interface but not the other
Date Sat, 22 Sep 2007 20:44:50 GMT
Hi,

This is quite a puzzle to me; I hope someone can help me out

CentOS 4.5 on a good AMD 64 machine with two interface cards eth0 going to
local network, and eth1 going out to the world

My ISP blocks port 80! (no surprise) but not port 88

So, I've configured apache to run on port 88 listening on all interfaces
instead. And here are the things that you may need to know

On local networks

>From any desktop client, http://192.168.30.30:88 <http://192.168.30.30:88/>
Works fine 

from local internet, tried to see if apache listening on the other interface

http://142.xx.xx.xx:88 <http://142.xx.xx.xx:88/>   is also working fine.

 

I can get the pages I want and everything looking smooth and cool.

 

On the internet side where the problem begins, 

Using www.megaproxy.com <http://www.megaproxy.com/>  to check the address
came back timed out the address of course used the address for the eth1
(internet address) and port 88 got connection timeout.

On one of my laptops, connected to the internet using dial-up connection and
closed local network connections (disabled) when I tried to access apache
got same result (connection timeout)

 

Did a telnet to my apache box from the dialup connection using 

telnet 142.x.x.x 88, got a blank screen, then typed GET <enter> and got the
correct page dumped on my screen from apache.

So I guess apache is working on the internet interface, but on that specific
interface it got shrug, blocked somehow that the GET isn't sent properly by
the browsers or is sent but got blocked somehow.

For the record, all these tests were made and iptables is turned off.

 

If you can help with this matter please contact me to share the my ip
address with you and we can work together on it.

After all , thanks a lot for the help in advance.

 


Mime
View raw message