httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Octavian Rasnita" <orasn...@gmail.com>
Subject [users@httpd] Re: Octavian Rasnita Fw: [users@httpd] Apache Win32 Binary, mod_perl and mod_fcgid working
Date Wed, 26 Sep 2007 18:30:32 GMT
> From: "Steffen" <info@apachelounge.com>
> To: <users@httpd.apache.org>
> Sent: Tuesday, September 25, 2007 10:51 PM
> Subject: [users@httpd] Apache Win32 Binary, mod_perl and mod_fcgid working
>
>
>> To inform you.
>>
>> We at http://www.apachelounge.com  made a binary available which works 
>> with mod-perl and mod-perl etc.
>>
>>
>> Steffen

Hi,

Thank you for your work. I hope I will be able to use it. For the moment I 
can't, and I don't know what could be the problem.

I've extracted the files from the archive 
httpd-2.2.6-patched-win32-x86-ssl.zip in C:\Apache2 and I included another 
configuration file using

Include e:/path/to/file.httpd

That file contains a virtualhost definition which uses mod_perl and calls a 
Catalyst framework module.

I tried:

c:\Apache2\bin> httpd

But it appeared an error message window telling that:

Visual Studio Just-In-Time Debugger
An unhandled win32 exception occurred in httpd.exe [2784].

And the server closed. In the error log, it appeared the following errors:

[Wed Sep 26 20:31:50 2007] [crit] master_main: create child process failed. 
Exiting.
[Wed Sep 26 20:31:50 2007] [error] (OS 6)The handle is invalid.  : Parent: 
SetEvent for child process 0 failed

Then I tried immediately to run a second time:

c:\Apache2\bin> httpd

It was all right. The server didn't give an error anymore, and I was able to 
access the Catalyst application, to login in the application...
I wanted to have the web server running on drive E:, so I copied the 
directory C:\Apache2 on E:\Apache2, I've modified all the paths from 
httpd.conf to start with e:/ instead of c:/, I uninstalled mod_perl and I 
installed it again on the new server to be sure it will be installed fine, 
then I tried to run:

e:\Apache2\bin> httpd

But again it gave that error window:

Visual Studio Just-In-Time Debugger
An unhandled win32 exception occurred in httpd.exe [2784].

However, this time there was no error in the error log. The log file was 
empty.

I've tried for more time to start the server, but with the same results, so 
I tried to use the server from c:\Apache2. I've even reinstalled mod_perl on 
this server, however I am not able to start it anymore. It makes that error 
Window appear and it doesn't print anything in the error log.
It is pretty strange, because I was able to use that server before (even 
though the first time I started it also gave that error).

Do you have any idea what could be the problem? Do you happen to know what 
"(OS 6)The handle is invalid." means?

Thank you very much.

Octavian


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message