httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kathi Porter <kp...@pacbell.net>
Subject Re: [users@httpd] Apache server service within a knoppix VMWare appliance?
Date Sun, 12 Aug 2007 22:57:48 GMT
Hi;
   
  Yes, I'm trying to reach http://localhost/ . I tried the command you gave me; initially
it errored-out with a "command not found". I browsed to that directory and found a file called
apache2 and used that instead. It was successful in that the system reported:
  "Starting Apache 2.0 web server....apache2: Could not determine the server's fully qualified
domain name, using 127.0.0.1 for ServerName." I tried the http://localhost/ again but now
I get no error message, but a blank web page. I then checked the httpd.conf file (per 
  http://apache-server.com/tutorials/ATgetting-started.html#installing ) and the ServerName
is localhost. Hmmm... any ideas? Hey this is kind of fun...
   
  Thanks & regards,
   
  KP

Victor Trac <victor.trac@gmail.com> wrote:
  On 8/12/07, Kathi Porter <kp288@pacbell.net> wrote:      Hi;
  I'm a brand-spanking new "newbie when it comes to Apache web server. I'll be atking a class
next spring, but wanted to install it and "play" with it a bit before then. 
I'm running a knoppix (linux/X Windows GUI) virtual appliance within a Windows XP enviroment
(a DSL modem connected to a wireless router, with a firewall enabled on the router). In looking
at the contents of the virtual HD root folder, the /etc/apache/ directory structure is present
and contains the Apache configuration files. So I took a "leap of faith" and assumed Apache
server was already installed & started on this image. But when I start the Firefox browser
and enter the url - http://localhost/ I got the following error message:
  "Unable to connect. Firefox can't establish a connection to the server at the locahost."
So this has to mean the service isn't running. I don't see it listed among the installed applications.
Does X Windows have an equivalent of the Microsoft Windows control panel? I checked under
the control center, system, utlities and settings but didn't find anything familiar. Do I
need to do the binary install from 
  http://www.uniontransit.com/apache/httpd/binaries/linux/
  Any tips or advice would be greatly appreciated.
  Thanks & regards,
  kp
   


Are you trying to reach "http://localhost" from the knoppix virtual machine or from the Windows
host?  Each operating system treats that address as its own.  If apache is actually running,
the localhost address will only work from inside the knoppix VM.  

By having /etc/apache, it is likely that apache is already installed on your virtual machine,
however, it may not be running.  You can try dropping down to a shell, typing "sudo /etc/init.d/apache
start" and then seeing if that works. 

You may have better luck asking the knoppix folks.

-- 
http://www.victortrac.com 

Mime
View raw message