httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joe Seeley" <joiey.see...@gmail.com>
Subject [users@httpd] Apache LDAP authentication prompts multiple times for login/password.
Date Thu, 16 Aug 2007 14:50:04 GMT
I am reposting this since I have not found a solution and never got a reply
on the original post.  I've seen through Google others with the same
problem, but never a solution.  I'm hopeful that someone knows what's going
on...

I am trying to use Apache LDAP authentication and proxying to make sure
users exist in our LDAP repository.  This is working, but the user is always
prompted to login multiple times.  In Firefox the users are prompted twice
for their login; in IE the users are prompted three times for their login.

My conf file looks something like this.

ProxyRequests Off
ProxyPass / http://localhost:5000/
ProxyPassReverse / http://localhost:5000
ProxyHTMLURLMap http://localhost:5000 http://1.2.3.4
ProxyHTMLURLMap http://localhost:5000 http://1.2.3.5

<Location />
  ProxyPassReverse http://localhost:5000
  SetOutputFilter proxy-html
  ProxyHTMLURLMap /     /
  AuthLDAPEnabled on
  AuthLDAPAuthoritative on
  AuthLDAPURL "ladp://myserver:3268/DC=FOO
,DC=BAR,DC=COM?sAMAccountName?sub?"
  AuthLDAPBindDN 'ldapuser@foo.bar.com"
  AuthLDAPBindPassword "password"
  AuthType Basic
  AuthName "Login in using your domain login."
  require valid-user
</Location>

If you see a mistake in my conf file, or understand why this is prompting
for multiple logins I would appreciate any advice.

Thanks,
         Joe

Mime
View raw message