httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dragon <dra...@crimson-dragon.com>
Subject Re: [users@httpd] OpenBSD 4.1 CGI issues
Date Thu, 23 Aug 2007 17:53:44 GMT
Israel Brewster wrote:
>First off, I apologize for asking a question that I know you get a
>lot, but I have just spent the last hour and a half beating my head
>against the wall and searching the internet trying to find a solution
>with no luck.
>
>Short version: I have an existing OpenBSD 4.0 box on which Apache
>(version 1.3.29) is working properly, including execution of CGI
>scripts. I am trying to move to a new machine with OpenBSD 4.1, so I
>started with a fresh OpenBSD 4.1 install, which comes with the same
>version of Apache as 4.0, and copied the httpd.conf file over from my
>old machine. After starting the web server, however, I found that it
>could not run any CGI scripts- always just giving me the following
>error:
>
>[Thu Aug 23 08:45:40 2007] [error] [client 127.0.0.1] Premature end
>of script headers: /cgi-bin/test-cgi
>
>The details: Aside from being OpenBSD 4.1, the new box is set up the
>same as the old one. I have checked and double checked the
>permissions on both the cgi files, including the test cgi included
>with the install, as well as the CGI folder. The test-cgi, as well as
>the printenv both run fine from a terminal window. I tried reverting
>to the factory default httpd.conf, with no luck. The permissions on
>the contents of the cgi-bin folder are as follows:
>
>ls -l /var/www/cgi-bin/
>total 212
>----------  1 root  bin     99072 Mar 10 16:41 bgplg
>drwxr-xr-x  2 root  daemon    512 Aug 23 07:59 nagios
>-rwxrwxrwx  1 root  bin       268 Mar 10 16:32 printenv
>-rwxrwxrwx  1 root  bin       757 Mar 10 16:32 test-cgi
>
>the cgi-bin folder itself has 755 permissions. The relevant section
>from the httpd.conf file is as follows:
>
>     ScriptAlias /cgi-bin/ "/var/www/cgi-bin/"
>
>     #
>     # "@@ServerRoot@@/cgi-bin" should be changed to whatever your
>ScriptAliased
>     # CGI directory exists, if you have that configured.
>     #
>     <Directory "/var/www/cgi-bin">
>         AllowOverride None
>         Options none
>         Order allow,deny
>         Allow from all
>     </Directory>
>
>I have tried adding an "AddHandler cgi-script .cgi" directive to that
>block, as one webpage I found suggested, as well as changing the
>"Option none" to "Options ExecCGI". I did, of course, restart the
>server between each configuration change. I have also tried with
>various different CGI scripts, most of which come from a fresh
>install. Nothing seems to make any difference- I still get the
>"premature end of script headers" error. If this was linux, i'd say
>check the SELinux settings, but it isn't. What am I missing here?
---------------- End original message. ---------------------

Are you sure that this new version of BSD doesn't have something 
similar to selinux that may be blocking your access?

It sure matches the symptoms one gets when selinux is the culprit on 
a linux installation.

Dragon

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
  Venimus, Saltavimus, Bibimus (et naribus canium capti sumus)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message