httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Beard" <je...@cyberxape.com>
Subject RE: [users@httpd] mod_jk error
Date Thu, 09 Aug 2007 23:51:59 GMT
Can you post the relevant configuration from workers.properties, apache
config and the server.xml please? 

 

 

Thanks,

 

Jeff

 

From: Sangoi, Nehal (Gexpro, consultant) [mailto:Nehal.Sangoi@gexpro.com] 
Sent: Thursday, August 09, 2007 3:22 PM
To: users@httpd.apache.org
Subject: RE: [users@httpd] mod_jk error

 

In continuation to below error, I have few more lines of log.

 

[Thu Aug 09 20:09:27 2007] [28566:38592] [debug]
wc_get_worker_for_name::jk_worker.c (114): found a worker iat1
[Thu Aug 09 20:09:27 2007] [28566:38592] [debug]
wc_get_name_for_type::jk_worker.c (290): Found worker type 'ajp13'
[Thu Aug 09 20:09:27 2007] [28566:38592] [debug] init_ws_service::mod_jk.c
(607): Service protocol=HTTP/1.1 method=GET host=(null) addr=10.33.84.4
name=gexprdweb.gexo.com port=7001 auth=(null) user=(null) laddr=10.33.4.151
raddr=10.33.84.4

 


==============================

 

[Thu Aug 09 20:10:50 2007] [28567:38592] [debug]
map_uri_to_worker::jk_uri_worker_map.c (616): Found a wildchar match
'/custdash/*=custdash1'
[Thu Aug 09 20:10:50 2007] [28567:38592] [debug] jk_handler::mod_jk.c
(2111): Into handler jakarta-servlet worker=custdash1 r->proxyreq=0
[Thu Aug 09 20:10:50 2007] [28567:38592] [debug]
wc_get_worker_for_name::jk_worker.c (114): found a worker custdash1
[Thu Aug 09 20:10:50 2007] [28567:38592] [debug]
wc_get_name_for_type::jk_worker.c (290): Found worker type 'ajp13'
[Thu Aug 09 20:10:50 2007] [28567:38592] [debug] init_ws_service::mod_jk.c
(607): Service protocol=HTTP/1.1 method=GET host=(null) addr=10.33.84.4
name=gexprdweb.gexo.com port=80 auth=(null) user=(null) laddr=10.33.4.151
raddr=10.33.84.4

 

==============================

 

[Thu Aug 09 20:49:17 2007] [29047:38592] [debug]
wc_get_worker_for_name::jk_worker.c (114): found a worker ecatalog1
[Thu Aug 09 20:49:17 2007] [29047:38592] [debug]
wc_get_name_for_type::jk_worker.c (290): Found worker type 'ajp13'
[Thu Aug 09 20:49:17 2007] [29047:38592] [debug] init_ws_service::mod_jk.c
(607): Service protocol=HTTP/1.1 method=GET host=(null) addr=10.33.84.4
name=gexprdweb.gexo.com port=8
0 auth=(null) user=(null) laddr=10.33.4.151 raddr=10.33.84.4

 

 

In the above bold lines, my URL port is getting changed from 7001 to 80
mysteriously. My instance is running over 7001 and application too, is
pointing to 7001 in all of the configuration. What could be the reason for
getting it redirected to port 80?

 

Thanks

Nehal

  _____  

From: Sangoi, Nehal (Gexpro, consultant) 
Sent: Wednesday, August 08, 2007 10:20 AM
To: users@httpd.apache.org
Subject: [users@httpd] mod_jk error

Hi

 

I am running apache 2.0.59 on linux machine with the mod_jk 1.2.19 binary as
connector to tomcat 5.5.23.

For one of the workers in mod_jk, its giving me following error.

 

[Tue Aug 07 20:41:03 2007] [22993:22208] [debug] jk_handler::mod_jk.c
(2047): Service finished with status=404 for worker=tss1

 

I tried to search the fressh mod_jk binary for the given apache version, but
it seems, its not available anymore. Hence, I tried to build from the source
code, but that option also did not work.

 

What could be the possible reason for the error mentioned and how it can be
resolved?

 

 

Thanks

Nehal

 


Mime
View raw message