httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shakeel Ahmad" <shakeel.ahmad...@gmail.com>
Subject [users@httpd] Please Help
Date Mon, 13 Aug 2007 05:46:12 GMT
-------------------------------------------------------------------------------------------
With Apache Running I find the following by using (netstat -an)
-------------------------------------------------------------------------------------------

Active Connections

  Proto  Local Address          Foreign Address        State
  TCP    0.0.0.0:80             0.0.0.0:0              LISTENING
  TCP    0.0.0.0:135            0.0.0.0:0              LISTENING
  TCP    0.0.0.0:445            0.0.0.0:0              LISTENING
  TCP    0.0.0.0:3306           0.0.0.0:0              LISTENING
  TCP    127.0.0.1:80           127.0.0.1:1078         CLOSE_WAIT
  TCP    127.0.0.1:80           127.0.0.1:1079         CLOSE_WAIT
  TCP    127.0.0.1:1045         0.0.0.0:0              LISTENING
  TCP    127.0.0.1:1078         127.0.0.1:80           FIN_WAIT_2
  TCP    127.0.0.1:1079         127.0.0.1:80           FIN_WAIT_2
  TCP    192.168.0.101:80       192.168.0.1:27066      ESTABLISHED
  TCP    192.168.0.101:139      0.0.0.0:0              LISTENING
  TCP    192.168.0.101:1046     192.168.0.1:1745       ESTABLISHED
  TCP    192.168.0.101:1076     192.168.0.1:8080       FIN_WAIT_2
  TCP    192.168.0.101:1081     192.168.0.1:8080       TIME_WAIT
  UDP    0.0.0.0:445            *:*
  UDP    0.0.0.0:500            *:*
  UDP    0.0.0.0:4500           *:*
  UDP    0.0.0.0:23281          *:*
  UDP    127.0.0.1:123          *:*
  UDP    127.0.0.1:1026         *:*
  UDP    127.0.0.1:1028         *:*
  UDP    127.0.0.1:1030         *:*
  UDP    127.0.0.1:1032         *:*
  UDP    127.0.0.1:1034         *:*
  UDP    127.0.0.1:1036         *:*
  UDP    127.0.0.1:1040         *:*
  UDP    127.0.0.1:1044         *:*
  UDP    127.0.0.1:1050         *:*
  UDP    127.0.0.1:1052         *:*
  UDP    127.0.0.1:1061         *:*
  UDP    127.0.0.1:1064         *:*
  UDP    127.0.0.1:1083         *:*
  UDP    127.0.0.1:1900         *:*
  UDP    192.168.0.101:123      *:*
  UDP    192.168.0.101:137      *:*
  UDP    192.168.0.101:138      *:*
  UDP    192.168.0.101:1900     *:*

-------------------------------------------------------------------------------------------------------------
With the Apache closed/shutdown I find the following by using (netstat -an)
-------------------------------------------------------------------------------------------------------------

 Proto  Local Address          Foreign Address        State
 TCP    0.0.0.0:135            0.0.0.0:0              LISTENING
 TCP    0.0.0.0:445            0.0.0.0:0              LISTENING
 TCP    0.0.0.0:3306           0.0.0.0:0              LISTENING
 TCP    127.0.0.1:1045         0.0.0.0:0              LISTENING
 TCP    192.168.0.101:139      0.0.0.0:0              LISTENING
 TCP    192.168.0.101:1046     192.168.0.1:1745       ESTABLISHED
 TCP    192.168.0.101:1086     192.168.0.1:1745       ESTABLISHED
 UDP    0.0.0.0:445            *:*
 UDP    0.0.0.0:500            *:*
 UDP    0.0.0.0:4500           *:*
 UDP    0.0.0.0:23281          *:*
 UDP    127.0.0.1:123          *:*
 UDP    127.0.0.1:1026         *:*
 UDP    127.0.0.1:1028         *:*
 UDP    127.0.0.1:1032         *:*
 UDP    127.0.0.1:1034         *:*
 UDP    127.0.0.1:1036         *:*
 UDP    127.0.0.1:1044         *:*
 UDP    127.0.0.1:1050         *:*
 UDP    127.0.0.1:1052         *:*
 UDP    127.0.0.1:1061         *:*
 UDP    127.0.0.1:1064         *:*
 UDP    127.0.0.1:1085         *:*
 UDP    127.0.0.1:1090         *:*
 UDP    127.0.0.1:1900         *:*
 UDP    192.168.0.101:123      *:*
 UDP    192.168.0.101:137      *:*
 UDP    192.168.0.101:138      *:*
 UDP    192.168.0.101:1900     *:*

--------------------------------------------------
In the error.log i find the followings:
--------------------------------------------------

[Mon Aug 13 08:57:30 2007] [notice] Apache/2.0.59 (Win32) configured -- resuming normal operations
[Mon Aug 13 08:57:30 2007] [notice] Server built: Jul 27 2006 15:55:03
[Mon Aug 13 08:57:30 2007] [notice] Parent: Created child process 1352
[Mon Aug 13 08:57:30 2007] [notice] Disabled use of AcceptEx() WinSock2 API
[Mon Aug 13 08:57:30 2007] [notice] Child 1352: Child process is running
[Mon Aug 13 08:57:30 2007] [notice] Child 1352: Acquired the start mutex.
[Mon Aug 13 08:57:30 2007] [notice] Child 1352: Starting 250 worker threads.
[Mon Aug 13 08:57:30 2007] [notice] Child 1352: Listening on port 80.
---------------------------------------------------------------------------------------------------------------------

But still when i try to open http://localhost or http://127.0.0.1 it continuously searches
but does'nt show any page or error.............

What is the problem now?
please help
---
Shakeel
  ----- Original Message ----- 
  From: Chakan 
  To: users@httpd.apache.org 
  Sent: Sunday, August 12, 2007 7:49 PM
  Subject: RE: [users@httpd] Problem


  Hello Shakeel,
  it looks like that another software use Port 80.

  Do the following steps please:

  1. Stop Apache
  2. Go to in the dos box (cmd)
  3. write netstat -an
  4. Check if Port 80 active (you should see something like this: 


  C:\>netstat -an

  Active Connections

    Proto  Local Address          Foreign Address        State
    TCP    0.0.0.0:80             0.0.0.0:0              LISTENING


  These steps are for Windows XP / Apache.


  Kind regards,
  Ch




------------------------------------------------------------------------------
  From: Shakeel Ahmad [mailto:shakeel.ahmad215@gmail.com] 
  Sent: 12 August 2007 11:55
  To: users@httpd.apache.org
  Subject: [users@httpd] Problem


  I am using internet through LAN. I have installed Apache server 2.0.59.

  After installation when i started the service, it was successfully started. but when i try
to open http://localhost it does'nt open it.

  the msg in errorlog file is:

  "[Sun Aug 12 14:49:27 2007] [error] (OS 10022)An invalid argument was supplied.  : Child
896: Encountered too many errors accepting client connections. Possible causes: dynamic address
renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive."

  Now the server shows that it is running but http://localhost or http://127.0.0.1 is not
working in my browser. i have disabled windows firewall, and my NOD32 Antivirus but it is
still not working.

  if i try to run the apache server through "DOS" it gives the following error.

  "(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally
permitted.  : make_sock: could not bind to address 0.0.0.0:80 no listening sockets available,
shutting down
  Unable to open logs"


  What should i do now..

  please help

  Shakeel Ahmad.
Mime
View raw message