httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Slive" <jos...@slive.ca>
Subject Re: [users@httpd] Problem getting script to work
Date Thu, 19 Jul 2007 15:43:04 GMT
On 7/19/07, Robert A. Rawlinson <rarawlinson@cinci.rr.com> wrote:
> To start I am working on a module that collects data. Since it does not
> run on my system I only want to have it run with out change for my
> system so when I return the module it will work properly with out
> changes. The module is located on the other system at:
> /usr/www/users/fgames/mufoncms.com. I only need it to run so I can check
> my changes work properly. I should only have to type in localhost on my
> browser to run it. I did not expect it to be so complicated :-)
> So bottom line is I want to put localhost in my browser and have it run
> the perl script sp_manage_sighting_reports.pl which is in directory
> /usr/www/users/fgames/mufoncms.com.
> Please if I have left anything out I will be glad to provide it. I have
> two books I have been studeing for several days now and haven't moved
> off ground zero.

There are lots of ways to accomplish this. Here is one:
Find the DocumentRoot directive in httpd.conf and set it as follows:
DocumentRoot /usr/www/users/fgames/mufoncms.com
Then add the following directive:
AddHandler cgi-script .pl
and make sure you have a <Directory> section that has at least
<Directory /usr/www/users/fgames/mufoncms.com>
Options ExecCGI
DirectoryIndex sp_manage_sighting_reports.pl
Order Allow,Deny
Allow from all
</Directory>

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message