httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Boyle Owen" <Owen.Bo...@swx.com>
Subject RE: [users@httpd] mod_ssl revisited
Date Thu, 12 Jul 2007 08:01:58 GMT
> -----Original Message-----
> From: Jeff Fulmer [mailto:jeff@joedog.org] 
> Sent: Wednesday, July 11, 2007 7:23 PM
> To: users@httpd.apache.org
> Subject: [users@httpd] mod_ssl revisited
> 
> Now I'm back to the original problem. I turned off name 
> resolution and I
> restarted apache. The virtual host for www.myserver.com:443 works as
> expected. However, this error continues to repeat itself in the logs:
> 
> [Wed Jul 11 13:14:39 2007] [info] Connection to child 22 established
> (server www.myserver.com:443, client 127.0.0.1)
> [Wed Jul 11 13:14:39 2007] [info] Seeding PRNG with 0 bytes of entropy
> [Wed Jul 11 13:14:39 2007] [debug] ssl_engine_kernel.c(1769): OpenSSL:
> Handshake: start
> [Wed Jul 11 13:14:39 2007] [debug] ssl_engine_kernel.c(1777): OpenSSL:
> Loop: before/accept initialization
> [Wed Jul 11 13:14:39 2007] [debug] ssl_engine_io.c(1523): OpenSSL: I/O
> error, 11 bytes expected to read on BIO#4046c990 [mem: 4048d2b0]
> [Wed Jul 11 13:14:39 2007] [debug] ssl_engine_kernel.c(1806): OpenSSL:
> Exit: error in SSLv2/v3 read client hello A
> [Wed Jul 11 13:14:39 2007] [info] (70014)End of file found: 
> SSL handshake
> interrupted by system [Hint: Stop button pressed in browser?!]
> [Wed Jul 11 13:14:39 2007] [info] Connection to child 22 closed with
> abortive shutdown(server www.myserver.com:443, client 127.0.0.1)

Look at the client IP ----------------------------------^^^^^^^^^

It's the loop-back address so the requests are coming from some process
on the server. What's in the corresponding access log (maybe nothing if
the session dies before SSL channel is open)?

Try snoop, top, and other system tools to see what is making the
requests...

Rgds,
Owen Boyle
Disclaimer: Any disclaimer attached to this message may be ignored. 

> 
> This occurs without *any* connections to the server. The 
> error continues
> about 30 to 40 times at short regular intervals. After that 
> it appears at
> irregular intervals while the server is running and under load. This
> occurs without *any* HTTPS requests to www.myserver.com:443.
> 
> Any thoughts?
> 
> Jeff
> 
> 
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP 
> Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
 
 
This message is for the named person's use only. It may contain confidential, proprietary
or legally privileged information. No confidentiality or privilege is waived or lost by any
mistransmission. If you receive this message in error, please notify the sender urgently and
then immediately delete the message and any copies of it from your system. Please also immediately
destroy any hardcopies of the message. You must not, directly or indirectly, use, disclose,
distribute, print, or copy any part of this message if you are not the intended recipient.
The sender's company reserves the right to monitor all e-mail communications through their
networks. Any views expressed in this message are those of the individual sender, except where
the message states otherwise and the sender is authorised to state them to be the views of
the sender's company.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message