httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Icy Blind <icebat...@hotmail.com>
Subject [users@httpd] mod_cache setup
Date Thu, 12 Jul 2007 15:37:59 GMT
HelloI'm trying to figure out if my simple mod_cache setup is
working. I compiled the mod_cache modules (mod_cache, mod_disk_cache
and mod_mem_cache) and put together a simple configuration. The server
starts up without a murmur, but I'm not sure that the caching is
actually taking place.
In my first test, I disabled the mem_cache by commenting it
out in the configuration, and wrapping its directives with an IfModule,
like so:<IfModule mod_mem_cache.c>  CacheIgnoreCacheControl On
  CacheDefaultExpire 120  CacheEnable mem http://192.168.1.100:80/test   MCacheSize 32768
  MCacheMaxObjectCount 100  MCacheMinObjectSize 1   MCacheMaxObjectSize 1048576
</IfModule>My mod_disk_cache setup looks like this:<IfModule mod_disk_cache.c>
 CacheIgnoreCacheControl On  CacheDefaultExpire 300  CacheRoot /apprel/tmp/htcache
  CacheEnable disk http://192.168.1.100:80/test </IfModule>I only make one of the above
modules available (LoadModule) at a time, along with mod_cache itself.The
/apprel/tmp/htcache directory is available to the apache user. In the
htdocs/test directory I have a simple html page. When I make a browser
request to that directory, the page is loaded. I immediately make a
change to the page, and reload it in the browser. The new page loads,
despite the fact that the 2 minutes are far from up.
I get the same result when I switch to mod_mem_cache.I
can't seem to find anything wrong with my config (I tried some bogus
cach directives, and the server wouldn't start, so I know that the
mod_cache pieces are there).
I don't see anything in the logs to let me believe that something is amiss.Any help would
be much appreciated.thanksWayne
_________________________________________________________________
Explore the seven wonders of the world
http://search.msn.com/results.aspx?q=7+wonders+world&mkt=en-US&form=QBRE
Mime
View raw message