httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From JJ <josh8...@yahoo.com>
Subject [users@httpd] Re: trouble sending environmental variable
Date Wed, 25 Jul 2007 02:51:44 GMT
Thanks Boyle and Joshua:
I believe Ive tried what you suggested.  I tried using
both SetEnv and PassEnv in the config file, and the
LD_LIBRARY_PATH is set correctly in a terminal when I
open a terminal up.  I usually use the session manager
to start apache, but the same problem occurs if I use
apachectl from a terminal.  And I can verify that the
LD_LIBRARY_PATH variable is set correctly by using
"print os.environ" in my python cgi script.  However,
the error logs have the following two line when I try
to import the python module that uses the *.so file: 
 
file=libacml.so [0];  needed by
/usr/lib64/python2.4/site-packages/scipy/optimize/_lbfgsb.so
[0], 
> find library=libacml.so [0]; searching, referer:
http://192.168.0.20/cgi-bin/upload.py search
path=\t\t(LD_LIBRARY_PATH), referer:
http://192.168.0.20/cgi-bin/upload.py

Does this mean that LD_LIBRARY_PATH has not been set,
or is it just using it as a variable and not printing
out the full path?  Could there be a permissions
problem with the LD_LIBRARY_PATH path?  Does apache
need some special permissions to access a *.so file? 
The path/file does already have read permissions. 
Mine seems to be a very strange problem.   

Joshua, my apachectl script does not include any
reference to an "envvars" script, so I dont think I
can follow that advice.
John  


      ____________________________________________________________________________________
Fussy? Opinionated? Impossible to please? Perfect.  Join Yahoo!'s user panel and lay it on
us. http://surveylink.yahoo.com/gmrs/yahoo_panel_invite.asp?a=7 


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message