httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gunther Mayer <gunther.ma...@googlemail.com>
Subject Re: [users@httpd] Errors with 2.2.4/mod_proxy_ajp and tomcat 5.5
Date Thu, 28 Jun 2007 16:22:24 GMT
Boyle Owen wrote:
>> However, I get spurious errors in my logs many times a day:
>>
>> [Thu Jun 28 11:33:43 2007] [error] [client 41.204.199.248] 
>> proxy: error 
>> processing body, referer: 
>> https://myserver.com/myapp/purchase.jsp?cid=5
>> 21&clr=true
>> [Thu Jun 28 11:33:43 2007] [error] proxy: got bad response (5) from 
>> [::1]:8009 (localhost)
>>     
>
> I guess these errors are coming out of mod_proxy as it tries to parse
> the response from tomcat. So it looks more like a problem at the tomcat
> side...
>
> - what do you see in the tomcat logs?
>   
At the same time, nothing. No errors or even informational stuff even 
though I have a fairly verbose jboss log.
> - what response code appears in the apache access log?
>   
Actually thanks for mentioning that, I see 503 response codes for the 
majority of such requests (a javascript related page). Our developer 
says that this is due to an obsolete feature in the code so we gotta fix 
our app. So I guess that the "bad response (5)"  message is about 
getting a 5xx error from Tomcat instead of a configuration or server 
problem.
> - what does the browser display (if you can reproduce these errors)?
>   
Well, I haven't been able to reproduce this myself so I have no clue 
what the browser displays or doesn't...

Gunther

Mime
View raw message