httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: [users@httpd] Apache, Windows XP, and mapped drives
Date Thu, 07 Jun 2007 20:41:15 GMT
Dragon wrote:
> William A. Rowe, Jr. wrote:
>> Jim Owens wrote:
>> > I just set up Apache 2.2.4 on a Windows XP system (from the current
>> > .msi), and I thought I’d share my findings about using mapped network
>> > drives.
>> >
>> > If anyone else is trying to deal with this, one workaround is to turn
>> > the Apache service off and run httpd.exe in a command-prompt window
>> > instead. That worked for me. I’ve added the httpd.exe to my
>> startup folder.
>>
>> It may also work if you change the dependencies of the service to wait to
>> start until windows networking is started.  This may simply be a race
>> condition where networking share components don't finish starting before
>> apache gets that far.
> ---------------- End original message. ---------------------
> 
> If what William states is in fact what is going on, you could probably
> still use Apache as a service if you start it manually instead of
> letting it start automatically.
> 
> Change the service properties from automatic to manual and then start it
> from the service window after you are sure the network is functioning.

Nice test case, yes!

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message