httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Graeme Fowler <gra...@graemef.net>
Subject Re: [users@httpd] Problems with mod_proxy etc and open proxy
Date Sat, 02 Jun 2007 08:07:42 GMT
On Sat, 2007-06-02 at 10:59 +1000, Philip Rhoades wrote:
> Not sure what you mean - do you mean load the page:
> 
>    http://www.sun.com/
> 
> into my browser on the same machine that is running httpd? - that just
> returns the sun page . .

No, I mean have you connected to your webserver using an appropriate
text-based client such as netcat or good ol' telnet and asked it for the
same thing? Something like this:

[graeme@ernie ~]$ telnet www.graemef.net 80
Trying 82.113.142.73...
Connected to www.graemef.net (82.113.142.73).
Escape character is '^]'.
GET http://www.sun.com/ HTTP/1.1
Host: www.graemef.net

HTTP/1.1 200 OK
Date: Sat, 02 Jun 2007 08:01:25 GMT
Server: Apache/2.2.0 (Fedora)
Last-Modified: Mon, 30 Oct 2006 20:13:59 GMT
ETag: "1297e0-1c7-e8fc0fc0"
Accept-Ranges: bytes
Content-Length: 455
Connection: close
Content-Type: text/html; charset=UTF-8

<snip the rest of mt default site>

Note: this does not return Sun's site!

Graeme


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message