httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Slive" <jos...@slive.ca>
Subject Re: [users@httpd] How to dsiplay photo from cgi-bin
Date Sun, 06 May 2007 13:38:39 GMT
On 5/6/07, Can Le <lecan75228@yahoo.com> wrote:
> On 2. Link suggested:
> Alias /cgi-bin /var/www/cgi-bin
> <Directory /var/www/cgi-bin>
>  AddHandler cgi-script cgi pl
>  Options ExecCGI
> </Directory>
>
> Should I add .jpg after "cgi pl " as "cgi pl jpg "

No. That is exactly the point: you DON'T want jpg to be treated as a cgi-script.

> or add image.jpg into another directory such as:
>
> /cgi-bin/photo/image.jpg ?

It doesn't matter whether it is in a subdirectory or not.

>
> The file image.jpg is also working OK in cgi-bin
> when the output text file has a html tag for
> <img src.....jpg
>
>  However, below url won't display:
>
> http://localhost/cgi-bin/image.jpg

For apache there is absolutely no difference between these two cases,
so it must be some other error you're making. Are you sure the img src
points to the same place? Are you sure you cleared your cache, etc?

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message