httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Res <...@ausics.net>
Subject [users@httpd] RES: Re: Apache 2.2.24, mysql auth and vhosts
Date Thu, 10 May 2007 11:19:32 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


This has been resolved.
A bug (a few actually) found in mod_dbd and patches commited 
to apache devel.

Quey, I see you have possible the same issue as I had, contact me 
off-list and I'll send you the patches that should fix the brokeness.


On Mon, 7 May 2007, Res wrote:

> Does anyone actually have 2.2.4 with mod_dbd and mysql authing working?
>
> I logged a bug as my testing shows it does not do what the docs state, and it 
> was closed with the simple statement of " it works for me " which might
> be great for him but not so for us :)
>
> If you do, am I leaving something out? Surely I dont have to go back to 
> apache 1.3 just to have working database authentication.
>
>
> in global I have :
> DBDriver mysql
> DBDParams "host=hidden dbname=hidden user=hidden pass=hidden"
> DBDPersist off
> (The docs state these can all even be used in vhost block, but apache fails 
> to restart saying they are NOT allowed there so I left them in global where 
> it appears happier)
>
>
> in a virtualhost block I have:
> <Directory /removed>
> AuthName "Members"
> AuthType Basic
> AuthBasicProvider dbd
> AuthDBDUserPWQuery "SELECT user_passwd FROM user_info WHERE user_name = %s"
> Require valid-user
> </Directory>
>
> ~# /usr/local/apache/bin/httpd  -l | grep dbd
>  mod_authn_dbd.c
>  mod_dbd.c
>
>
> Am using apr_dbd_mysql.c in /usr/local/src/httpd-2.2.4/srclib/apr-util/dbd
> did a buildconf and ./configure --with-apr=../apr  etc...
>
> ~#ldd /usr/local/apache/bin/httpd | grep libmysqlclient_r
>        libmysqlclient_r.so.15 => /usr/lib/mysql/libmysqlclient_r.so.15 
> (0x40038000)
>
> Now mysql reports it connects and logins in to the database but does not do a 
> query, it disconnects right away,  the apache logs report
> "No DBD Authn configured!" and the user gets a 500 int server error..
>
> Anyone have any pointers?
>
> TIA
> Res
>
>

- -- 

Cheers
Res

Vote for your favourite MTA at  http://polls.ausics.net/v3.php
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFGQv/IsWhAmSIQh7MRAkycAKCOae2MV6NdglD+s4Vo31UB3TNHEACdHUFB
iZVo3HMy98lqiZ55DWRUEQI=
=d9zR
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message