httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Malladi, Sasikanth " <sasikanth.mall...@citi.com>
Subject [users@httpd] Undefined symbol ap_run_http_method
Date Wed, 30 May 2007 19:54:52 GMT
All,

I'm trying to configure my Apache webserver with a Web Authentication
system.

When I try to start up my server, I'm getting the following error:

root@nusnj7-qes01:/usr/local/apache2/bin$ ./apachectl start

httpd: Syntax error on line 39 of /usr/local/apache2/conf/httpd.conf:
Cannot load /export/opt/SiteMinder/webagent5QMR7/lib/libmod_sm20.so
into server: ld.so.1: httpd: fatal: relocation error: file /export/
opt/
SiteMinder/webagent5QMR7/lib/libmod_sm20.so: symbol
ap_run_http_method: referenced symbol not found

I initially thought it might an LD_LIBRARY_PATH issue but an ldd on /
export/opt/SiteMinder/webagent5QMR7/lib/libmod_sm20.so told me that
everything is well defined.

When I ran nm on this file and grepped for the missing symbol, it
showed up:

root@nusnj7-qes01:/usr/local/apache2/bin$ /usr/xpg4/bin/nm   /export/
opt/SiteMinder/webagent5QMR7/lib/libmod_sm20.so | grep http
[5799]  |         0|       0|FUNC |GLOB |0    |UNDEF  |
ap_run_http_method

Hence there is an undefined symbol in this file.

How do I fix this?

Thanks in advance,
Sashi 

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message